summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-12 21:52:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-12 21:52:40 +0000
commitd1f9930ce33bd0634bb0acf315c18d906f6b9bd0 (patch)
tree0355505c8926ad35540ce25dda8ec102b4b0dbbc
parentReleasing debian version 2.0.0+debian-2. (diff)
downloaddnscap-d1f9930ce33bd0634bb0acf315c18d906f6b9bd0.tar.xz
dnscap-d1f9930ce33bd0634bb0acf315c18d906f6b9bd0.zip
Merging upstream version 2.0.1+debian.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGES8
-rw-r--r--configure.ac2
-rw-r--r--plugins/eventlog/eventlog.c2
-rw-r--r--rpm/dnscap.spec7
4 files changed, 16 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index c6a0909..b8fc6a2 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,11 @@
+2021-03-11 Jerry Lundström
+
+ Release 2.0.1
+
+ Fixed incorrect line break in eventlog's (plugin) output.
+
+ 5df363c remove trailing newline
+
2021-02-12 Jerry Lundström
Release 2.0.0
diff --git a/configure.ac b/configure.ac
index f43cce5..ac6c156 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@
# POSSIBILITY OF SUCH DAMAGE.
AC_PREREQ(2.61)
-AC_INIT([dnscap], [2.0.0], [dnscap-users@dns-oarc.net], [dnscap], [https://github.com/DNS-OARC/dnscap/issues])
+AC_INIT([dnscap], [2.0.1], [dnscap-users@dns-oarc.net], [dnscap], [https://github.com/DNS-OARC/dnscap/issues])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnscap.c])
AC_CONFIG_HEADER([src/config.h])
diff --git a/plugins/eventlog/eventlog.c b/plugins/eventlog/eventlog.c
index 93d0d15..14606f8 100644
--- a/plugins/eventlog/eventlog.c
+++ b/plugins/eventlog/eventlog.c
@@ -374,7 +374,7 @@ void eventlog_output(const char* descr, iaddr from, iaddr to, uint8_t proto, uns
ldns_buffer_clear(buf);
if (ldns_rdf2buffer_str(buf, ldns_rr_owner(qd)) == LDNS_STATUS_OK) {
- fprintf(out, " name=%s\n", (char*)ldns_buffer_begin(buf));
+ fprintf(out, " name=%s", (char*)ldns_buffer_begin(buf));
} else {
fprintf(out, " **ERROR parsing response record**\n");
ldns_pkt_free(pkt);
diff --git a/rpm/dnscap.spec b/rpm/dnscap.spec
index 3aab83f..45eae76 100644
--- a/rpm/dnscap.spec
+++ b/rpm/dnscap.spec
@@ -1,5 +1,5 @@
Name: dnscap
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: Network capture utility designed specifically for DNS traffic
Group: Productivity/Networking/DNS/Utilities
@@ -60,6 +60,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Thu Mar 11 2021 Jerry Lundström <lundstrom.jerry@gmail.com> 2.0.1-1
+- Release 2.0.1
+ * Fixed incorrect line break in eventlog's (plugin) output.
+ * Commits:
+ 5df363c remove trailing newline
* Fri Feb 12 2021 Jerry Lundström <lundstrom.jerry@gmail.com> 2.0.0-1
- Release 2.0.0
* This major release contains three backward incompatible changes, two