summaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-11 12:02:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-11 12:02:40 +0000
commit4e0143a3bd62defb458342444822a445d8513107 (patch)
tree4b8ea3f51cf497c3e8539be41a16242c19054be1 /src/test/Makefile.in
parentAdding upstream version 2.2.0. (diff)
downloaddnscap-upstream/2.2.1.tar.xz
dnscap-upstream/2.2.1.zip
Adding upstream version 2.2.1.upstream/2.2.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/Makefile.in')
-rw-r--r--src/test/Makefile.in15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/test/Makefile.in b/src/test/Makefile.in
index 1aff4ee..5c51d7c 100644
--- a/src/test/Makefile.in
+++ b/src/test/Makefile.in
@@ -481,11 +481,12 @@ CLEANFILES = test*.log test*.trs \
test13.out \
test14.out \
test_regex_match.out \
- edns.out
+ edns.out \
+ test_icmp.out
TESTS = test1.sh test2.sh test3.sh test4.sh test5.sh test6.sh test7.sh \
test8.sh test9.sh test10.sh test11.sh test12.sh test13.sh test14.sh \
- test_regex_match.sh test_edns.sh
+ test_regex_match.sh test_edns.sh test_icmp.sh
EXTRA_DIST = $(TESTS) \
dns.gold dns.pcap \
@@ -501,7 +502,8 @@ EXTRA_DIST = $(TESTS) \
dns6.pcap test10.gold \
test14.gold \
test_regex_match.gold \
- edns.pcap edns.gold
+ edns.pcap edns.gold \
+ gen_icmp.py icmp.pcap icmp.gold
all: all-am
@@ -803,6 +805,13 @@ test_edns.sh.log: test_edns.sh
--log-file $$b.log --trs-file $$b.trs \
$(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
"$$tst" $(AM_TESTS_FD_REDIRECT)
+test_icmp.sh.log: test_icmp.sh
+ @p='test_icmp.sh'; \
+ b='test_icmp.sh'; \
+ $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+ --log-file $$b.log --trs-file $$b.trs \
+ $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+ "$$tst" $(AM_TESTS_FD_REDIRECT)
.test.log:
@p='$<'; \
$(am__set_b); \