summaryrefslogtreecommitdiffstats
path: root/plugins/anonmask/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/anonmask/Makefile.am')
-rw-r--r--plugins/anonmask/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugins/anonmask/Makefile.am b/plugins/anonmask/Makefile.am
new file mode 100644
index 0000000..48f5a10
--- /dev/null
+++ b/plugins/anonmask/Makefile.am
@@ -0,0 +1,23 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+CLEANFILES = *.gcda *.gcno *.gcov
+
+AM_CFLAGS = -I$(srcdir) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/isc \
+ $(SECCOMPFLAGS)
+
+pkglib_LTLIBRARIES = anonmask.la
+anonmask_la_SOURCES = anonmask.c
+anonmask_la_LDFLAGS = -module -avoid-version
+
+TESTS = test1.sh test2.sh test3.sh
+
+EXTRA_DIST = $(TESTS) test1.gold test2.gold
+CLEANFILES += test1.out test2.out
+
+if ENABLE_GCOV
+gcov-local:
+ for src in $(anonmask_la_SOURCES); do \
+ gcov -o .libs -l -r -s "$(srcdir)" "$$src"; \
+ done
+endif