summaryrefslogtreecommitdiffstats
path: root/plugins/eventlog
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/eventlog')
-rw-r--r--plugins/eventlog/Makefile.am5
-rw-r--r--plugins/eventlog/Makefile.in5
2 files changed, 6 insertions, 4 deletions
diff --git a/plugins/eventlog/Makefile.am b/plugins/eventlog/Makefile.am
index e29af63..d18531c 100644
--- a/plugins/eventlog/Makefile.am
+++ b/plugins/eventlog/Makefile.am
@@ -4,11 +4,12 @@ CLEANFILES = *.gcda *.gcno *.gcov
AM_CFLAGS = -I$(srcdir) \
-I$(top_srcdir)/src \
-I$(top_srcdir)/isc \
- $(SECCOMPFLAGS)
+ $(SECCOMPFLAGS) \
+ $(libldns_CFLAGS)
pkglib_LTLIBRARIES = eventlog.la
eventlog_la_SOURCES = eventlog.c
-eventlog_la_LDFLAGS = -module -avoid-version
+eventlog_la_LDFLAGS = -module -avoid-version $(libldns_LIBS)
TESTS = test1.sh
EXTRA_DIST = $(TESTS)
diff --git a/plugins/eventlog/Makefile.in b/plugins/eventlog/Makefile.in
index 6dd2dcc..fe6a9a6 100644
--- a/plugins/eventlog/Makefile.in
+++ b/plugins/eventlog/Makefile.in
@@ -520,11 +520,12 @@ CLEANFILES = *.gcda *.gcno *.gcov test1.out *.pcap-dist
AM_CFLAGS = -I$(srcdir) \
-I$(top_srcdir)/src \
-I$(top_srcdir)/isc \
- $(SECCOMPFLAGS)
+ $(SECCOMPFLAGS) \
+ $(libldns_CFLAGS)
pkglib_LTLIBRARIES = eventlog.la
eventlog_la_SOURCES = eventlog.c
-eventlog_la_LDFLAGS = -module -avoid-version
+eventlog_la_LDFLAGS = -module -avoid-version $(libldns_LIBS)
TESTS = test1.sh
EXTRA_DIST = $(TESTS)
all: all-am