summaryrefslogtreecommitdiffstats
path: root/plugins/ipcrypt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ipcrypt/Makefile.am')
-rw-r--r--plugins/ipcrypt/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/ipcrypt/Makefile.am b/plugins/ipcrypt/Makefile.am
new file mode 100644
index 0000000..64effb7
--- /dev/null
+++ b/plugins/ipcrypt/Makefile.am
@@ -0,0 +1,24 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+CLEANFILES = *.gcda *.gcno *.gcov
+
+AM_CFLAGS = -I$(srcdir) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/isc \
+ $(SECCOMPFLAGS)
+
+pkglib_LTLIBRARIES = ipcrypt.la
+ipcrypt_la_SOURCES = ipcrypt.c
+ipcrypt_la_LDFLAGS = -module -avoid-version
+
+TESTS = test1.sh test2.sh test3.sh test4.sh
+
+EXTRA_DIST = $(TESTS) test1.gold test2.gold test3.gold
+CLEANFILES += test1.out test2.out test3.out test3.pcap.20161020.152301.075993 \
+ test3.pcap.20181127.155200.414188 test4.tmp
+
+if ENABLE_GCOV
+gcov-local:
+ for src in $(ipcrypt_la_SOURCES); do \
+ gcov -o .libs -l -r -s "$(srcdir)" "$$src"; \
+ done
+endif