summaryrefslogtreecommitdiffstats
path: root/plugins/txtout/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/txtout/Makefile.am')
-rw-r--r--plugins/txtout/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/plugins/txtout/Makefile.am b/plugins/txtout/Makefile.am
new file mode 100644
index 0000000..c802b92
--- /dev/null
+++ b/plugins/txtout/Makefile.am
@@ -0,0 +1,22 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+CLEANFILES = *.gcda *.gcno *.gcov
+
+AM_CFLAGS = -I$(srcdir) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/isc \
+ $(SECCOMPFLAGS) $(libldns_CFLAGS)
+
+pkglib_LTLIBRARIES = txtout.la
+txtout_la_SOURCES = txtout.c
+txtout_la_LDFLAGS = -module -avoid-version $(libldns_LIBS)
+
+TESTS = test1.sh
+EXTRA_DIST = $(TESTS)
+CLEANFILES += test1.out *.pcap-dist
+
+if ENABLE_GCOV
+gcov-local:
+ for src in $(txtout_la_SOURCES); do \
+ gcov -o .libs -l -r -s "$(srcdir)" "$$src"; \
+ done
+endif