summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:23:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:23:28 +0000
commit11fa4c54635765dceecc0901becef11490c5e94e (patch)
treef67180f85d26b18d648c92a169c57df84b070d92 /pyproject.toml
parentAdding upstream version 0.9.0. (diff)
downloadeos-downloader-11fa4c54635765dceecc0901becef11490c5e94e.tar.xz
eos-downloader-11fa4c54635765dceecc0901becef11490c5e94e.zip
Adding upstream version 0.10.0.upstream/0.10.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--pyproject.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f98c4ee..f125def 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.9.0"
+version = "v0.10.0"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -22,7 +22,7 @@ dependencies = [
"scp",
"tqdm",
"loguru",
- "rich>=13.5.2,<13.7.0",
+ "rich>=13.5.2,<13.8.0",
"cvprac>=1.0.7",
"click~=8.1.6",
"click-help-colors~=0.9",
@@ -51,8 +51,8 @@ requires-python = ">=3.8"
[project.optional-dependencies]
dev = [
- "isort==5.12.0",
- "mypy==1.5.1",
+ "mypy==1.8.0",
+ "isort==5.13.2",
"mypy-extensions>=0.4.3",
"pre-commit>=2.20.0",
"pylint",
@@ -94,7 +94,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.9.0"
+current_version = "0.10.0"
version_pattern = "MAJOR.MINOR.PATCH"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true