summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 20:09:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 20:09:42 +0000
commitc961c66297d5f5732d6d1ed1ee7af22b03e6879e (patch)
tree1844b742f17ca97ff73c212bc59701bbd7fad3b8 /pyproject.toml
parentReleasing debian version 0.10.1-1. (diff)
downloadeos-downloader-c961c66297d5f5732d6d1ed1ee7af22b03e6879e.tar.xz
eos-downloader-c961c66297d5f5732d6d1ed1ee7af22b03e6879e.zip
Merging upstream version 0.10.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--pyproject.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b06934a..fbd2982 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.10.1"
+version = "v0.10.2"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -22,11 +22,11 @@ dependencies = [
"scp",
"tqdm",
"loguru",
- "rich>=13.5.2,<13.8.0",
+ "rich>=13.5.2",
"cvprac>=1.0.7",
- "click~=8.1.6",
- "click-help-colors~=0.9",
- "pydantic>2.0.0,<3.0.0",
+ "click>=8.1.6",
+ "click-help-colors>=0.9",
+ "pydantic>2.0.0",
]
keywords = ["eos_downloader", "Arista", "eos", "cvp", "network", "automation", "networking", "devops", "netdevops"]
classifiers = [
@@ -51,7 +51,7 @@ requires-python = ">=3.8"
[project.optional-dependencies]
dev = [
- "mypy==1.8.0",
+ "mypy==1.10.0",
"isort==5.13.2",
"mypy-extensions>=0.4.3",
"pre-commit>=2.20.0",
@@ -62,7 +62,7 @@ dev = [
"pytest-html>=3.1.1",
"pytest-metadata>=1.11.0",
"pylint-pydantic>=0.2.4",
- "tox~=4.11",
+ "tox>=4.11",
"types-PyYAML",
"types-paramiko",
"types-requests",
@@ -94,7 +94,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.10.1"
+current_version = "0.10.2"
version_pattern = "MAJOR.MINOR.PATCH"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true