summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1c0698f..c744814 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-.PHONY: dist test install clean twine
+.PHONY: dist test install clean twine auto-completion
install:
pip3 install -e .
@@ -10,3 +10,10 @@ twine:
twine upload dist/*
clean:
git clean -fdx
+auto-completion:
+ @ mkdir -p auto-completion/bash
+ @ mkdir -p auto-completion/zsh
+ @ mkdir -p auto-completion/fish
+ register-python-argcomplete gita -s bash > auto-completion/bash/.gita-completion.bash
+ register-python-argcomplete gita -s zsh > auto-completion/zsh/_gita
+ register-python-argcomplete gita -s fish > auto-completion/fish/gita.fish