summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c67d4a7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+.PHONY: dist test install clean twine
+
+install:
+ pip3 install -e .
+test: clean
+ pytest tests --cov=./gita $(TEST_ARGS) -n=auto
+dist: clean
+ python3 setup.py sdist
+twine:
+ twine upload dist/*
+clean:
+ git clean -fdx