summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4950b49..394d0c2 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ with open("README.md", encoding="utf-8") as f:
setup(
name="gita",
packages=["gita"],
- version="0.16.6",
+ version="0.16.7.2",
license="MIT",
description="Manage multiple git repos with sanity",
long_description=long_description,
@@ -19,6 +19,7 @@ setup(
author_email="zhou.dong@gmail.com",
entry_points={"console_scripts": ["gita = gita.__main__:main"]},
python_requires="~=3.6",
+ install_requires=["argcomplete"],
classifiers=[
"Development Status :: 4 - Beta",
"Intended Audience :: Developers",
@@ -29,10 +30,12 @@ setup(
"Topic :: Software Development :: Version Control :: Git",
"Topic :: Terminals",
"Topic :: Utilities",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
],
include_package_data=True,
)