summaryrefslogtreecommitdiffstats
path: root/.devcontainer/devcontainer.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:03:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:03:03 +0000
commitde139943d8272773b5f19ed824d687b0232b9ba3 (patch)
tree47e73755bffd41bdde2d59d76cc595f5a1fa75d4 /.devcontainer/devcontainer.json
parentAdding upstream version 0.19.0~dev. (diff)
downloadgitlint-de139943d8272773b5f19ed824d687b0232b9ba3.tar.xz
gitlint-de139943d8272773b5f19ed824d687b0232b9ba3.zip
Adding upstream version 0.19.1.upstream/0.19.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.devcontainer/devcontainer.json')
-rw-r--r--.devcontainer/devcontainer.json11
1 files changed, 8 insertions, 3 deletions
diff --git a/.devcontainer/devcontainer.json b/.devcontainer/devcontainer.json
index 5889037..65fcc1c 100644
--- a/.devcontainer/devcontainer.json
+++ b/.devcontainer/devcontainer.json
@@ -22,7 +22,11 @@
"settings": {
"python.defaultInterpreterPath": "/usr/local/bin/python",
"python.linting.enabled": true,
- "python.linting.pylintEnabled": true,
+ "python.formatting.provider": "black",
+ "python.formatting.blackArgs": [
+ "--config",
+ "./pyproject.toml"
+ ],
"python.formatting.autopep8Path": "/usr/local/py-utils/bin/autopep8",
"python.formatting.blackPath": "/usr/local/py-utils/bin/black",
"python.formatting.yapfPath": "/usr/local/py-utils/bin/yapf",
@@ -31,12 +35,13 @@
"python.linting.mypyPath": "/usr/local/py-utils/bin/mypy",
"python.linting.pycodestylePath": "/usr/local/py-utils/bin/pycodestyle",
"python.linting.pydocstylePath": "/usr/local/py-utils/bin/pydocstyle",
- "python.linting.pylintPath": "/usr/local/py-utils/bin/pylint"
},
// Add the IDs of extensions you want installed when the container is created.
"extensions": [
"ms-python.python",
- "ms-python.vscode-pylance"
+ "ms-python.vscode-pylance",
+ "charliermarsh.ruff",
+ "tamasfe.even-better-toml"
]
}
},