diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2021-12-04 03:31:41 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2021-12-04 03:31:41 +0000 |
commit | 72b8c35be4293bd21de123854491c658c53af100 (patch) | |
tree | 735464cc081879561927a37650b1102beaa1f4f9 /setup.py | |
parent | Adding upstream version 0.16.0. (diff) | |
download | gitlint-72b8c35be4293bd21de123854491c658c53af100.tar.xz gitlint-72b8c35be4293bd21de123854491c658c53af100.zip |
Adding upstream version 0.17.0.upstream/0.17.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 50 |
1 files changed, 4 insertions, 46 deletions
@@ -1,12 +1,6 @@ #!/usr/bin/env python from __future__ import print_function -from setuptools import setup, find_packages -import io -import re -import os -import platform -import sys - +from setuptools import setup description = "Git commit message linter written in python, checks your commit messages for style." long_description = """ @@ -29,16 +23,11 @@ Source code on `github.com/jorisroovers/gitlint`_. """ -# shamelessly stolen from mkdocs' setup.py: https://github.com/mkdocs/mkdocs/blob/master/setup.py -def get_version(package): - """Return package version as listed in `__version__` in `init.py`.""" - init_py = io.open(os.path.join(package, '__init__.py'), encoding="UTF-8").read() - return re.search("__version__ = ['\"]([^'\"]+)['\"]", init_py).group(1) - +version = "0.17.0" setup( name="gitlint", - version=get_version("gitlint"), + version=version, description=description, long_description=long_description, classifiers=[ @@ -60,14 +49,8 @@ setup( ], python_requires=">=3.6", install_requires=[ - 'Click==8.0.1', - 'arrow==1.2.0', + 'gitlint-core[trusted-deps]==' + version, ], - extras_require={ - ':sys_platform != "win32"': [ - 'sh==1.14.2', - ], - }, keywords='gitlint git lint', author='Joris Roovers', url='https://jorisroovers.github.io/gitlint', @@ -76,29 +59,4 @@ setup( 'Source': 'https://github.com/jorisroovers/gitlint', }, license='MIT', - package_data={ - 'gitlint': ['files/*'] - }, - packages=find_packages(exclude=["examples"]), - entry_points={ - "console_scripts": [ - "gitlint = gitlint.cli:cli", - ], - }, ) - -# Print a red deprecation warning for python < 3.6 users -if sys.version_info[:2] < (3, 6): - msg = "\033[31mDEPRECATION: You're using a python version that has reached end-of-life. " + \ - "Gitlint does not support Python < 3.6" + \ - "Please upgrade your Python to 3.6 or above.\033[0m" - print(msg) - -# Print a warning message for Windows users -PLATFORM_IS_WINDOWS = "windows" in platform.system().lower() -if PLATFORM_IS_WINDOWS: - msg = "\n\n\n\n\n****************\n" + \ - "WARNING: Gitlint support for Windows is still experimental and there are some known issues: " + \ - "https://github.com/jorisroovers/gitlint/issues?q=is%3Aissue+is%3Aopen+label%3Awindows " + \ - "\n*******************" - print(msg) |