summaryrefslogtreecommitdiffstats
path: root/gitlint-core/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'gitlint-core/setup.py')
-rw-r--r--gitlint-core/setup.py50
1 files changed, 26 insertions, 24 deletions
diff --git a/gitlint-core/setup.py b/gitlint-core/setup.py
index 952dd7f..8917e27 100644
--- a/gitlint-core/setup.py
+++ b/gitlint-core/setup.py
@@ -1,5 +1,4 @@
#!/usr/bin/env python
-from __future__ import print_function
from setuptools import setup, find_packages
import io
import re
@@ -32,7 +31,7 @@ Source code on `github.com/jorisroovers/gitlint`_.
# shamelessly stolen from mkdocs' setup.py: https://github.com/mkdocs/mkdocs/blob/master/setup.py
def get_version(package):
"""Return package version as listed in `__version__` in `init.py`."""
- init_py = io.open(os.path.join(package, '__init__.py'), encoding="UTF-8").read()
+ init_py = open(os.path.join(package, "__init__.py"), encoding="UTF-8").read()
return re.search("__version__ = ['\"]([^'\"]+)['\"]", init_py).group(1)
@@ -50,38 +49,37 @@ setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Environment :: Console",
"Intended Audience :: Developers",
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
- "License :: OSI Approved :: MIT License"
+ "License :: OSI Approved :: MIT License",
],
python_requires=">=3.6",
install_requires=[
- 'Click>=8',
- 'arrow>=1',
+ "Click>=8",
+ "arrow>=1",
'sh>=1.13.0 ; sys_platform != "win32"',
],
extras_require={
- 'trusted-deps': [
- 'Click==8.0.3',
- 'arrow==1.2.1',
+ "trusted-deps": [
+ "Click==8.0.3",
+ "arrow==1.2.1",
'sh==1.14.2 ; sys_platform != "win32"',
],
},
- keywords='gitlint git lint',
- author='Joris Roovers',
- url='https://jorisroovers.github.io/gitlint',
+ keywords="gitlint git lint",
+ author="Joris Roovers",
+ url="https://jorisroovers.github.io/gitlint",
project_urls={
- 'Documentation': 'https://jorisroovers.github.io/gitlint',
- 'Source': 'https://github.com/jorisroovers/gitlint',
- },
- license='MIT',
- package_data={
- 'gitlint': ['files/*']
+ "Documentation": "https://jorisroovers.github.io/gitlint",
+ "Source": "https://github.com/jorisroovers/gitlint",
},
+ license="MIT",
+ package_data={"gitlint": ["files/*"]},
packages=find_packages(exclude=["examples"]),
entry_points={
"console_scripts": [
@@ -92,16 +90,20 @@ setup(
# Print a red deprecation warning for python < 3.6 users
if sys.version_info[:2] < (3, 6):
- msg = "\033[31mDEPRECATION: You're using a python version that has reached end-of-life. " + \
- "Gitlint does not support Python < 3.6" + \
- "Please upgrade your Python to 3.6 or above.\033[0m"
+ msg = (
+ "\033[31mDEPRECATION: You're using a python version that has reached end-of-life. "
+ + "Gitlint does not support Python < 3.6"
+ + "Please upgrade your Python to 3.6 or above.\033[0m"
+ )
print(msg)
# Print a warning message for Windows users
PLATFORM_IS_WINDOWS = "windows" in platform.system().lower()
if PLATFORM_IS_WINDOWS:
- msg = "\n\n\n\n\n****************\n" + \
- "WARNING: Gitlint support for Windows is still experimental and there are some known issues: " + \
- "https://github.com/jorisroovers/gitlint/issues?q=is%3Aissue+is%3Aopen+label%3Awindows " + \
- "\n*******************"
+ msg = (
+ "\n\n\n\n\n****************\n"
+ + "WARNING: Gitlint support for Windows is still experimental and there are some known issues: "
+ + "https://github.com/jorisroovers/gitlint/issues?q=is%3Aissue+is%3Aopen+label%3Awindows "
+ + "\n*******************"
+ )
print(msg)