summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 13:44:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 13:52:52 +0000
commitaec415329e7f6c06e13efb6a16ecbb0915fddd5c (patch)
tree37395c85e122e6857eb55811b3e0d8e0c0d1868a
parentMoving patches to version gnome-shell version specific directory. (diff)
downloadgnome-shell-extensions-extra-aec415329e7f6c06e13efb6a16ecbb0915fddd5c.tar.xz
gnome-shell-extensions-extra-aec415329e7f6c06e13efb6a16ecbb0915fddd5c.zip
Updating rules to build for gnome-shell version 44.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e71b69c..d5036d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,19 @@
#!/usr/bin/make -f
+GNOME_SHELL_VERSION = 44
+
%:
dh ${@} --no-parallel
execute_after_dh_auto_clean:
+ rm -f extensions/current
+
# remove generated files
- rm -f extensions/*/*/schemas/gschemas.compiled
- rm -f extensions/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+ rm -f extensions/44/*/*/schemas/gschemas.compiled
+ rm -f extensions/44/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+
+execute_before_dh_auto_build:
+ ln -s $(GNOME_SHELL_VERSION) extensions/current
execute_after_dh_auto_install:
# removing unused files