summaryrefslogtreecommitdiffstats
path: root/extensions/hibernate-status
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-05 08:57:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-05 09:07:55 +0000
commit3713a4d3bf8ae2df7d02e63b5b827353e5121d19 (patch)
treecd422f385434aa71efd7f501b0da711ea93080a6 /extensions/hibernate-status
parentAdding debian version 20230204-1. (diff)
downloadgnome-shell-extensions-extra-3713a4d3bf8ae2df7d02e63b5b827353e5121d19.tar.xz
gnome-shell-extensions-extra-3713a4d3bf8ae2df7d02e63b5b827353e5121d19.zip
Merging upstream version 20230205.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--extensions/hibernate-status.mk55
-rw-r--r--extensions/hibernate-status/.gitignore (renamed from hibernate-status/.gitignore)0
-rw-r--r--extensions/hibernate-status/LICENSE (renamed from hibernate-status/LICENSE)0
-rw-r--r--extensions/hibernate-status/Makefile (renamed from hibernate-status/Makefile)0
-rw-r--r--extensions/hibernate-status/README.md (renamed from hibernate-status/README.md)0
-rwxr-xr-xextensions/hibernate-status/buildforupload.sh (renamed from hibernate-status/buildforupload.sh)0
-rw-r--r--extensions/hibernate-status/confirmDialog.js (renamed from hibernate-status/confirmDialog.js)0
-rw-r--r--extensions/hibernate-status/extension.js (renamed from hibernate-status/extension.js)0
-rw-r--r--extensions/hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po (renamed from hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po)0
-rw-r--r--extensions/hibernate-status/metadata.json (renamed from hibernate-status/metadata.json)0
-rw-r--r--extensions/hibernate-status/prefs.js (renamed from hibernate-status/prefs.js)0
-rw-r--r--extensions/hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml (renamed from hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml)0
25 files changed, 55 insertions, 0 deletions
diff --git a/extensions/hibernate-status.mk b/extensions/hibernate-status.mk
new file mode 100644
index 0000000..05651b5
--- /dev/null
+++ b/extensions/hibernate-status.mk
@@ -0,0 +1,55 @@
+# Progress Linux: gnome-shell-extensions-extra
+
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# libglib2.0-bin
+
+SHELL := sh -e
+
+EXTENSION := hibernate-status
+UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/metadata.json)
+
+all:
+
+test:
+
+build:
+
+install:
+ $(MAKE) -C $(EXTENSION) DESTDIR=$(DESTDIR) install
+
+ # removing unused files
+ rm -f $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)/LICENSE
+ rm -f $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)/README.md
+
+uninstall:
+ rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+ $(MAKE) -C $(EXTENSION) clean
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+ rm -rf $(EXTENSION)
+ git clone https://github.com/arelange/gnome-shell-extension-$(EXTENSION) $(EXTENSION)
+ rm -rf $(EXTENSION)/.git
diff --git a/hibernate-status/.gitignore b/extensions/hibernate-status/.gitignore
index 68270f9..68270f9 100644
--- a/hibernate-status/.gitignore
+++ b/extensions/hibernate-status/.gitignore
diff --git a/hibernate-status/LICENSE b/extensions/hibernate-status/LICENSE
index d6a9326..d6a9326 100644
--- a/hibernate-status/LICENSE
+++ b/extensions/hibernate-status/LICENSE
diff --git a/hibernate-status/Makefile b/extensions/hibernate-status/Makefile
index 3378024..3378024 100644
--- a/hibernate-status/Makefile
+++ b/extensions/hibernate-status/Makefile
diff --git a/hibernate-status/README.md b/extensions/hibernate-status/README.md
index ff88abd..ff88abd 100644
--- a/hibernate-status/README.md
+++ b/extensions/hibernate-status/README.md
diff --git a/hibernate-status/buildforupload.sh b/extensions/hibernate-status/buildforupload.sh
index d2c705c..d2c705c 100755
--- a/hibernate-status/buildforupload.sh
+++ b/extensions/hibernate-status/buildforupload.sh
diff --git a/hibernate-status/confirmDialog.js b/extensions/hibernate-status/confirmDialog.js
index 62069e2..62069e2 100644
--- a/hibernate-status/confirmDialog.js
+++ b/extensions/hibernate-status/confirmDialog.js
diff --git a/hibernate-status/extension.js b/extensions/hibernate-status/extension.js
index 6e0b248..6e0b248 100644
--- a/hibernate-status/extension.js
+++ b/extensions/hibernate-status/extension.js
diff --git a/hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po
index 32e541d..32e541d 100644
--- a/hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/cs/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po
index 3fdb8c2..3fdb8c2 100644
--- a/hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/de/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po
index 92c14bc..92c14bc 100644
--- a/hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/es/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po
index e4edef0..e4edef0 100644
--- a/hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/fa/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po
index 9dca80d..9dca80d 100644
--- a/hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/fr/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po
index a41e5ac..a41e5ac 100644
--- a/hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/it/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po
index 6853171..6853171 100644
--- a/hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/nl/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po
index 25debf8..25debf8 100644
--- a/hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/oc/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po
index 57b735c..57b735c 100644
--- a/hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/pl/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po
index 143129c..143129c 100644
--- a/hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/pt/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po
index 326481a..326481a 100644
--- a/hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/pt_BR/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po
index c279315..c279315 100644
--- a/hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/ru/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po
index 68c6b8c..68c6b8c 100644
--- a/hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/uk/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po b/extensions/hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po
index be1a6b1..be1a6b1 100644
--- a/hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po
+++ b/extensions/hibernate-status/locale/zh_CN/LC_MESSAGES/hibernate-status-button.po
diff --git a/hibernate-status/metadata.json b/extensions/hibernate-status/metadata.json
index 94098fe..94098fe 100644
--- a/hibernate-status/metadata.json
+++ b/extensions/hibernate-status/metadata.json
diff --git a/hibernate-status/prefs.js b/extensions/hibernate-status/prefs.js
index cdcd50e..cdcd50e 100644
--- a/hibernate-status/prefs.js
+++ b/extensions/hibernate-status/prefs.js
diff --git a/hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml b/extensions/hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml
index f29ec1c..f29ec1c 100644
--- a/hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml
+++ b/extensions/hibernate-status/schemas/org.gnome.shell.extensions.hibernate-status-button.gschema.xml