summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e71b69c..d5036d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,19 @@
#!/usr/bin/make -f
+GNOME_SHELL_VERSION = 44
+
%:
dh ${@} --no-parallel
execute_after_dh_auto_clean:
+ rm -f extensions/current
+
# remove generated files
- rm -f extensions/*/*/schemas/gschemas.compiled
- rm -f extensions/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+ rm -f extensions/44/*/*/schemas/gschemas.compiled
+ rm -f extensions/44/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+
+execute_before_dh_auto_build:
+ ln -s $(GNOME_SHELL_VERSION) extensions/current
execute_after_dh_auto_install:
# removing unused files