summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-11-10 13:07:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-11-10 13:07:06 +0000
commit070d942ad3783755e920206bddb4d847ca45b27e (patch)
treecf06b5ac35d495c907fd18a5d04b07411739ed83
parentReleasing debian version 1.5.7-1. (diff)
downloadidentify-070d942ad3783755e920206bddb4d847ca45b27e.tar.xz
identify-070d942ad3783755e920206bddb4d847ca45b27e.zip
Merging upstream version 1.5.9.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--identify/extensions.py2
-rw-r--r--setup.cfg2
2 files changed, 3 insertions, 1 deletions
diff --git a/identify/extensions.py b/identify/extensions.py
index 5d5a685..22b85c5 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -178,6 +178,7 @@ EXTENSIONS = {
'ts': {'text', 'ts'},
'tsx': {'text', 'tsx'},
'ttf': {'binary', 'ttf'},
+ 'twig': {'text', 'twig'},
'txsprofile': {'text', 'ini', 'txsprofile'},
'txt': {'text', 'plain-text'},
'v': {'text', 'verilog'},
@@ -256,6 +257,7 @@ NAMES = {
'PATENTS': EXTENSIONS['txt'],
'Pipfile': EXTENSIONS['toml'],
'Pipfile.lock': EXTENSIONS['json'],
+ 'PKGBUILD': {'text', 'bash', 'pkgbuild', 'alpm'},
'README': EXTENSIONS['txt'],
'Rakefile': EXTENSIONS['rb'],
'setup.cfg': EXTENSIONS['ini'],
diff --git a/setup.cfg b/setup.cfg
index 2b90b9f..722410c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 1.5.7
+version = 1.5.9
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown