summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-02-19 08:09:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-02-19 08:09:26 +0000
commit281b734ba9ca1e8f65855aee46a7d93edd63bae6 (patch)
tree987755dcb213d15eda79136d31b9a61f7dfc948e
parentReleasing debian version 2.4.9-1. (diff)
downloadidentify-281b734ba9ca1e8f65855aee46a7d93edd63bae6.tar.xz
identify-281b734ba9ca1e8f65855aee46a7d93edd63bae6.zip
Merging upstream version 2.4.10.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--README.md2
-rw-r--r--identify/extensions.py1
-rw-r--r--setup.cfg2
3 files changed, 3 insertions, 2 deletions
diff --git a/README.md b/README.md
index 788b7c4..c209782 100644
--- a/README.md
+++ b/README.md
@@ -80,7 +80,7 @@ optional arguments:
$ identify-cli setup.py; echo $?
["file", "non-executable", "python", "text"]
0
-$ identify setup.py --filename-only; echo $?
+$ identify-cli setup.py --filename-only; echo $?
["python", "text"]
0
$ identify-cli wat.wat; echo $?
diff --git a/identify/extensions.py b/identify/extensions.py
index b0979ba..3cd1ab2 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -99,6 +99,7 @@ EXTENSIONS = {
'js': {'text', 'javascript'},
'json': {'text', 'json'},
'jsonnet': {'text', 'jsonnet'},
+ 'json5': {'text', 'json5'},
'jsx': {'text', 'jsx'},
'key': {'text', 'pem'},
'kml': {'text', 'kml', 'xml'},
diff --git a/setup.cfg b/setup.cfg
index 9cd3fd1..40bad04 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.4.9
+version = 2.4.10
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown