summaryrefslogtreecommitdiffstats
path: root/tests/identify_test.py
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:56:03 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:56:03 +0000
commit4c39f473af4e8dfbc724a16e3dcf2f8d8c7c6373 (patch)
treedb58a17ae3aa1ec3f499a25f3691187780dcdb4a /tests/identify_test.py
parentAdding upstream version 2.5.31. (diff)
downloadidentify-4c39f473af4e8dfbc724a16e3dcf2f8d8c7c6373.tar.xz
identify-4c39f473af4e8dfbc724a16e3dcf2f8d8c7c6373.zip
Adding upstream version 2.5.33.upstream/2.5.33
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to '')
-rw-r--r--tests/identify_test.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/identify_test.py b/tests/identify_test.py
index ac458df..bb8aba5 100644
--- a/tests/identify_test.py
+++ b/tests/identify_test.py
@@ -151,6 +151,7 @@ def test_tags_from_path_plist_text(tmpdir):
@pytest.mark.parametrize(
('filename', 'expected'),
(
+ ('.salt-lint', {'text', 'salt-lint', 'yaml'}),
('test.py', {'text', 'python'}),
('test.mk', {'text', 'makefile'}),
('Makefile', {'text', 'makefile'}),
@@ -170,6 +171,7 @@ def test_tags_from_path_plist_text(tmpdir):
('build.jenkinsfile', {'text', 'groovy', 'jenkins'}),
('meson.build', {'text', 'meson'}),
('meson_options.txt', {'text', 'plain-text', 'meson'}),
+ ('Vagrantfile', {'text', 'ruby'}),
# does not set binary / text
('f.plist', {'plist'}),