diff options
-rw-r--r-- | README.md | 2 | ||||
-rw-r--r-- | identify/extensions.py | 1 | ||||
-rw-r--r-- | setup.cfg | 2 |
3 files changed, 3 insertions, 2 deletions
@@ -80,7 +80,7 @@ optional arguments: $ identify-cli setup.py; echo $? ["file", "non-executable", "python", "text"] 0 -$ identify setup.py --filename-only; echo $? +$ identify-cli setup.py --filename-only; echo $? ["python", "text"] 0 $ identify-cli wat.wat; echo $? diff --git a/identify/extensions.py b/identify/extensions.py index b0979ba..3cd1ab2 100644 --- a/identify/extensions.py +++ b/identify/extensions.py @@ -99,6 +99,7 @@ EXTENSIONS = { 'js': {'text', 'javascript'}, 'json': {'text', 'json'}, 'jsonnet': {'text', 'jsonnet'}, + 'json5': {'text', 'json5'}, 'jsx': {'text', 'jsx'}, 'key': {'text', 'pem'}, 'kml': {'text', 'kml', 'xml'}, @@ -1,6 +1,6 @@ [metadata] name = identify -version = 2.4.9 +version = 2.4.10 description = File identification library for Python long_description = file: README.md long_description_content_type = text/markdown |