summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:02:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 11:02:06 +0000
commit36df1518d61259005423b84e0d63a4ecae53895e (patch)
tree96916fd7bd9811e85b7c934a5a3012cc4333d5c8 /Makefile
parentAdding upstream version 0~20240209. (diff)
downloadinotify-info-36df1518d61259005423b84e0d63a4ecae53895e.tar.xz
inotify-info-36df1518d61259005423b84e0d63a4ecae53895e.zip
Adding upstream version 0.0.1.upstream/0.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 643c951..6bf0e0a 100644
--- a/Makefile
+++ b/Makefile
@@ -109,3 +109,9 @@ clean:
$(VERBOSE_PREFIX)$(RM) $(OBJS)
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.d)
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.dwo)
+
+define RELEASE_RULES
+inotify-info-$(TAG).tar.gz:
+ git archive --prefix=inotify-info-$(TAG)/ $(TAG) | gzip -n > $$@
+endef
+$(foreach TAG,$(shell git tag 2>/dev/null),$(eval $(RELEASE_RULES)))