summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-13 10:57:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-13 10:57:06 +0000
commitb765a6db5fc0b679751f7aabf507f090d1a3db40 (patch)
treea6820e5e5c2906ae0326ca17a0192da73c7f44f3 /Makefile
parentAdding upstream version 0.0.2. (diff)
downloadinotify-info-b765a6db5fc0b679751f7aabf507f090d1a3db40.tar.xz
inotify-info-b765a6db5fc0b679751f7aabf507f090d1a3db40.zip
Adding upstream version 0.0.3.upstream/0.0.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cb95bb4..9163e54 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,9 @@ ifeq ($(CFG), debug)
ASAN ?= 1
endif
+PREFIX ?= /usr/local
+BINDIR := $(PREFIX)/bin
+
LD = $(CC)
RM = rm -f
MKDIR = mkdir -p
@@ -121,6 +124,16 @@ clean:
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.d)
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.dwo)
+.PHONY: install
+
+install: all
+ install -D $(PROJ) $(BINDIR)/$(NAME)
+
+.PHONY: uninstall
+
+uninstall:
+ $(RM) $(BINDIR)/$(NAME)
+
define RELEASE_RULES
inotify-info-$(TAG).tar.gz:
git archive --prefix=inotify-info-$(TAG)/ v$(TAG) | gzip -n > $$@