summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/patches/debian/0001-march.patch19
-rw-r--r--debian/patches/series1
2 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-march.patch b/debian/patches/debian/0001-march.patch
new file mode 100644
index 0000000..c53c5a9
--- /dev/null
+++ b/debian/patches/debian/0001-march.patch
@@ -0,0 +1,19 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Building without -march=native (Closes: #1071076).
+
+diff -Naurp inotify-info.orig/Makefile inotify-info/Makefile
+--- inotify-info.orig/Makefile
++++ inotify-info/Makefile
+@@ -33,10 +33,10 @@ ifneq ($(COMPILER),clang)
+ WARNINGS += -Wsuggest-attribute=format -Wall
+ endif
+
+-CFLAGS = $(WARNINGS) -march=native -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
++CFLAGS = $(WARNINGS) -fno-exceptions -gdwarf-4 -g2 -ggnu-pubnames -gsplit-dwarf
+ CFLAGS += -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64
+ CXXFLAGS = -fno-rtti -Woverloaded-virtual
+-LDFLAGS = -march=native -gdwarf-4 -g2 -Wl,--build-id=sha1
++LDFLAGS = -gdwarf-4 -g2 -Wl,--build-id=sha1
+ LIBS = -Wl,--no-as-needed -lm -ldl -lpthread -lstdc++
+
+ CFILES = \
diff --git a/debian/patches/series b/debian/patches/series
index 80e0c95..b1f010a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
+debian/0001-march.patch
debian/0001-dwz.patch