summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cb95bb4..9163e54 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,9 @@ ifeq ($(CFG), debug)
ASAN ?= 1
endif
+PREFIX ?= /usr/local
+BINDIR := $(PREFIX)/bin
+
LD = $(CC)
RM = rm -f
MKDIR = mkdir -p
@@ -121,6 +124,16 @@ clean:
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.d)
$(VERBOSE_PREFIX)$(RM) $(OBJS:.o=.dwo)
+.PHONY: install
+
+install: all
+ install -D $(PROJ) $(BINDIR)/$(NAME)
+
+.PHONY: uninstall
+
+uninstall:
+ $(RM) $(BINDIR)/$(NAME)
+
define RELEASE_RULES
inotify-info-$(TAG).tar.gz:
git archive --prefix=inotify-info-$(TAG)/ v$(TAG) | gzip -n > $$@