summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 11:18:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 11:36:18 +0000
commit955406a2ac61bb0e8b16b05343d33466fb09851f (patch)
tree86bf8dc8bac28447087d6254d49f752fc824c233
parentAdding upstream version 1.9.1. (diff)
downloadiredis-955406a2ac61bb0e8b16b05343d33466fb09851f.tar.xz
iredis-955406a2ac61bb0e8b16b05343d33466fb09851f.zip
Adding debian version 1.9.1-1.debian/1.9.1-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog5
-rw-r--r--debian/control26
-rw-r--r--debian/copyright38
-rw-r--r--debian/local/setup.py37
-rwxr-xr-xdebian/rules22
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
7 files changed, 132 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5f860f3
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+iredis (1.9.1-1) sid; urgency=medium
+
+ * Initial upload to sid (Closes: #954408).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 07 Feb 2021 12:17:57 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b64fd56
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,26 @@
+Source: iredis
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Section: database
+Priority: optional
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/iredis
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/iredis
+Homepage: https://iredis.io
+Build-Depends:
+ debhelper-compat (= 13),
+ dh-python,
+ python3,
+ python3-setuptools,
+Rules-Requires-Root: no
+Standards-Version: 4.5.1
+
+Package: iredis
+Architecture: all
+Depends:
+ python3-importlib-resources,
+ python3-pendulum,
+ python3-pytzdata,
+ ${misc:Depends},
+ ${python3:Depends},
+Description: CLI for Redis
+ IRedis is a command line interface for Redis with auto-completion and syntax
+ highlighting.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..08c93fd
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,38 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: IRedis
+Upstream-Contact: laixintao <laixintaoo@gmail.com>
+Source: https://github.com/laixintao/iredis/releases
+
+Files: *
+Copyright: 2019-2020 laixintao <laixintaoo@gmail.com>
+License: BSD-3-clause
+
+Files: debian/*
+Copyright: 2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+License: BSD-3-clause
+
+License: BSD-3-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are met:
+ .
+ * Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+ .
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+ .
+ * Neither the name of dbcli nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+ SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+ CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+ OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/local/setup.py b/debian/local/setup.py
new file mode 100644
index 0000000..48c148e
--- /dev/null
+++ b/debian/local/setup.py
@@ -0,0 +1,37 @@
+# -*- coding: utf-8 -*-
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+
+import os.path
+
+readme = ''
+here = os.path.abspath(os.path.dirname(__file__))
+readme_path = os.path.join(here, 'README.rst')
+if os.path.exists(readme_path):
+ with open(readme_path, 'rb') as stream:
+ readme = stream.read().decode('utf8')
+
+
+setup(
+ long_description=readme,
+ name='iredis',
+ version='1.9.1',
+ description='Terminal client for Redis with auto-completion and syntax highlighting.',
+ python_requires='==3.*,>=3.6.0',
+ project_urls={"homepage": "https://github.com/laixintao/iredis", "repository": "https://github.com/laixintao/iredis"},
+ author='laixintao',
+ author_email='laixintao1995@163.com',
+ license='BSD-3-Clause',
+ keywords='Redis key-value store Commandline tools Redis Client',
+ classifiers=['Development Status :: 4 - Beta', 'Environment :: Console', 'Environment :: Console :: Curses', 'Environment :: MacOS X', 'Operating System :: OS Independent', 'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.8', 'Topic :: Database', 'License :: OSI Approved :: MIT License', 'Intended Audience :: Developers'],
+ entry_points={"console_scripts": ["iredis = iredis.entry:main"]},
+ packages=['iredis', 'iredis.data', 'iredis.data.commands'],
+ package_dir={"": "."},
+ package_data={"iredis.data": ["*.csv", "*.json"], "iredis.data.commands": ["*.md"]},
+ install_requires=['click==7.*,>=7.0.0', 'configobj==5.*,>=5.0.0', 'importlib-resources==1.0.2', 'mistune==0.*,>=0.8.0', 'pendulum==2.*,>=2.0.0', 'prompt-toolkit==3.*,>=3.0.0', 'pygments==2.*,>=2.0.0', 'redis==3.*,>=3.0.0', 'wcwidth==0.1.9'],
+ extras_require={"dev": ["pexpect==4.*,>=4.7.0", "pytest==5.*,>=5.0.0"]},
+)
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f321962
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=iredis
+
+%:
+ dh ${@} --buildsystem=pybuild --with python3
+
+execute_before_dh_auto_clean:
+ cp debian/local/setup.py setup.py
+
+execute_after_dh_auto_clean:
+ rm -f setup.py
+
+execute_before_dh_auto_configure:
+ cp debian/local/setup.py setup.py
+
+execute_after_dh_auto_install:
+ mkdir -p debian/iredis/usr/lib/python3/dist-packages/iredis/data
+ cp iredis/data/iredisrc debian/iredis/usr/lib/python3/dist-packages/iredis/data/iredisrc
+
+override_dh_auto_test:
+ # disabled
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..12835b4
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=filenamemangle=s/.+\/v?(\d\S+)\.tar\.gz/iredis-$1\.tar\.gz/ \
+https://github.com/laixintao/iredis/releases .*/v?(\d\S+)\.tar\.gz