summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-28 18:29:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-28 18:29:36 +0000
commit89f80db0e0383eda73b61b23a4747185c8505e46 (patch)
tree7b26817ed957116ecab11b7b67f55592064860c0 /pyproject.toml
parentAdding upstream version 1.9.4. (diff)
downloadiredis-a9fe25c67ad6705a8a5d66cd4a8b6c68c6f341ab.tar.xz
iredis-a9fe25c67ad6705a8a5d66cd4a8b6c68c6f341ab.zip
Adding upstream version 1.10.0.upstream/1.10.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index aba1fba..f722d8b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "iredis"
-version = "1.9.4"
+version = "1.10.0"
description = "Terminal client for Redis with auto-completion and syntax highlighting."
authors = ["laixintao <laixintao1995@163.com>"]
readme = 'README.md'
@@ -19,6 +19,7 @@ classifiers = [
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Topic :: Database",
"License :: OSI Approved :: MIT License",
"Intended Audience :: Developers",
@@ -31,7 +32,7 @@ packages = [
[tool.poetry.dependencies]
python = "^3.6"
-redis = "^3"
+redis = "^3.4.0"
prompt_toolkit = "^3"
Pygments = "^2"
mistune = "^0.8"
@@ -43,7 +44,7 @@ importlib-resources = "^5.1.0"
wcwidth = "0.1.9"
[tool.poetry.dev-dependencies]
-pytest = "^5"
+pytest = "^6"
pexpect = "^4.7"
[tool.poetry.scripts]