summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-04-03 07:38:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-04-03 07:38:49 +0000
commita10a53dd934a67693d068bba16e635ddabcdabe2 (patch)
tree262c2fe9621c7903046080bc3fe9812b423c0dda /src/meson.build
parentAdding upstream version 1.3. (diff)
downloadlibnvme-a10a53dd934a67693d068bba16e635ddabcdabe2.tar.xz
libnvme-a10a53dd934a67693d068bba16e635ddabcdabe2.zip
Adding upstream version 1.4.upstream/1.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 1186e81..3732f8c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -23,13 +23,16 @@ mi_sources = [
'nvme/mi-mctp.c',
]
-if conf.get('CONFIG_JSONC')
+if json_c_dep.found()
sources += 'nvme/json.c'
+else
+ sources += 'nvme/no-json.c'
endif
deps = [
json_c_dep,
openssl_dep,
+ keyutils_dep,
]
mi_deps = [