summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-14 18:53:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-14 18:53:09 +0000
commit3945f3269b3e2763faa1ab22d225ca4dd1856b82 (patch)
tree7e96ec768baa3807ce3a1076a74037a287f4caa8 /test/meson.build
parentInitial commit. (diff)
downloadlibnvme-upstream/1.0.tar.xz
libnvme-upstream/1.0.zip
Adding upstream version 1.0.upstream/1.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..193d558
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,39 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+#
+# This file is part of libnvme.
+# Copyright (c) 2021 Dell Inc.
+#
+# Authors: Martin Belanger <Martin.Belanger@dell.com>
+
+# These tests all require interaction with a real NVMe device, so we don't
+# define as meson unit-tests, and therefore get run as part of the 'test'
+# target. However, they're available for developer use, when hardware is
+# available.
+main = executable(
+ 'main-test',
+ ['test.c'],
+ dependencies: libuuid_dep,
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+cpp = executable(
+ 'test-cpp',
+ ['cpp.cc'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+register = executable(
+ 'test-register',
+ ['register.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)
+
+zns = executable(
+ 'test-zns',
+ ['zns.c'],
+ link_with: libnvme,
+ include_directories: [incdir, internal_incdir]
+)