summaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-17 19:03:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-17 19:03:18 +0000
commit3e2509d4c8e0cdbe9c3c39a802f1086701f613dc (patch)
tree6e5bfbb597f089825b8931c9f4528ef59c08d4c2 /.travis.yml
parentAdding upstream version 1.5.0. (diff)
downloadlitecli-3e2509d4c8e0cdbe9c3c39a802f1086701f613dc.tar.xz
litecli-3e2509d4c8e0cdbe9c3c39a802f1086701f613dc.zip
Adding upstream version 1.6.0.upstream/1.6.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml29
1 files changed, 0 insertions, 29 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 896e7f7..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,29 +0,0 @@
-language: python
-python:
- - "3.6"
-
-matrix:
- include:
- - python: 3.7
- dist: xenial
- sudo: true
-
-install:
- - pip install -r requirements-dev.txt
- - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then pip install black; fi
- - pip install -e .
-
-script:
- - ./setup.py test --pytest-args="--cov-report= --cov=litecli"
- - coverage report
- - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then ./setup.py lint; fi
-
-after_success:
- - codecov
-
-notifications:
- webhooks:
- urls:
- - YOUR_WEBHOOK_URL
- on_success: change # options: [always|never|change] default: always
- on_failure: always # options: [always|never|change] default: always