summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-01 04:03:01 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-01 04:03:01 +0000
commit3726f0df980b93da2cb53e3791d9d2e489508e73 (patch)
tree5b6a73bc0821d368a8224791482bd6113e4966fd /setup.py
parentAdding upstream version 1.7.0. (diff)
downloadlitecli-3726f0df980b93da2cb53e3791d9d2e489508e73.tar.xz
litecli-3726f0df980b93da2cb53e3791d9d2e489508e73.zip
Adding upstream version 1.8.0.upstream/1.8.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 808b165..0ff4eeb 100755
--- a/setup.py
+++ b/setup.py
@@ -24,11 +24,11 @@ readme = open_file("README.md")
install_requirements = [
"click >= 4.1",
- "Pygments>=1.6,<=2.11.1",
+ "Pygments>=1.6",
"prompt_toolkit>=3.0.3,<4.0.0",
"sqlparse",
"configobj >= 5.0.5",
- "cli_helpers[styles] >= 1.0.1",
+ "cli_helpers[styles] >= 2.2.1",
]
@@ -57,10 +57,10 @@ setup(
"Operating System :: Unix",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: SQL",
"Topic :: Database",
"Topic :: Database :: Front-Ends",