summaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini19
1 files changed, 11 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index c1c81ea..b2bf266 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,14 @@
[tox]
-envlist = py37, py38, py39, py310
+envlist = py,style
[testenv]
-deps = pytest
- mock
- pexpect
- behave
- coverage
-commands = python setup.py test
-passenv = PYTEST_DATABASE
+deps = uv
+commands = uv pip install -e .[dev]
+ coverage run -m pytest -v tests
+ coverage report -m
+
+[testenv:style]
+skip_install = true
+deps = ruff
+commands = ruff check --fix
+ ruff format