summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-06 14:11:06 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-06 14:11:06 +0000
commit2bfc9d607ef5fad85db6551531432edeff3ddb89 (patch)
treee6276a9d700bed7da7846a038166f45eef54b102
parentAdding debian version 1.2-2. (diff)
downloadlunzip-2bfc9d607ef5fad85db6551531432edeff3ddb89.tar.xz
lunzip-2bfc9d607ef5fad85db6551531432edeff3ddb89.zip
Adding debian version 1.2-3.debian/1.2-3
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control9
-rw-r--r--debian/lunzip.postinst24
-rw-r--r--debian/lunzip.prerm22
-rwxr-xr-xdebian/rules11
5 files changed, 69 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 979ae11..37dde71 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+lunzip (1.2-3) experimental; urgency=low
+
+ * Sorting targets in rules.
+ * Updating package descriptions.
+ * Adding alternative handling for /usr/bin/lzip.
+ * Removing unused info files removal in rules.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Tue, 26 Mar 2013 10:41:23 +0100
+
lunzip (1.2-2) unstable; urgency=low
* Removing all references to my old email address.
diff --git a/debian/control b/debian/control
index 9aa7229..5c1a553 100644
--- a/debian/control
+++ b/debian/control
@@ -9,20 +9,21 @@ Homepage: http://www.nongnu.org/lzip/lunzip.html
Package: lunzip
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
+Breaks: lzip (<< 1.15~)
Enhances: lzip
-Description: data compressor based on the LZMA algorithm (uncompressor)
+Description: data compressor based on the LZMA algorithm (decompressor)
Lzip is a lossless data compressor based on the LZMA algorithm, with very safe
integrity checking and a user interface similar to the one of gzip or bzip2.
.
- This package contains the uncompressor.
+ This package contains the decompressor.
Package: lunzip-dbg
Section: debug
Priority: extra
Architecture: any
Depends: ${misc:Depends}, lunzip (= ${binary:Version})
-Description: data compressor based on the LZMA algorithm (uncompressor debug)
+Description: data compressor based on the LZMA algorithm (decompressor debug)
Lzip is a lossless data compressor based on the LZMA algorithm, with very safe
integrity checking and a user interface similar to the one of gzip or bzip2.
.
- This package contains the debugging symbols for the uncompressor.
+ This package contains the debugging symbols for the decompressor.
diff --git a/debian/lunzip.postinst b/debian/lunzip.postinst
new file mode 100644
index 0000000..4ed0891
--- /dev/null
+++ b/debian/lunzip.postinst
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ configure)
+ update-alternatives --quiet \
+ --install /usr/bin/lzip lzip /usr/bin/lzip.decompressor 10 \
+ --slave /usr/share/man/man1/lzip.1.gz lzip.1.gz /usr/share/man/man1/lzip.decompressor.1.gz
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/lunzip.prerm b/debian/lunzip.prerm
new file mode 100644
index 0000000..e731041
--- /dev/null
+++ b/debian/lunzip.prerm
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ remove|upgrade|deconfigure)
+ update-alternatives --quiet --remove lzip /usr/bin/lzip.decompressor
+ ;;
+
+ failed-upgrade)
+
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
index 5f3d9a7..66d4e2d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,8 +6,15 @@
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lunzip
-override_dh_strip:
- dh_strip --dbg-package=lunzip-dbg
+ # alernative handling
+ mv debian/lunzip/usr/bin/lunzip debian/lunzip/usr/bin/lzip.decompressor
+ mv debian/lunzip/usr/share/man/man1/lunzip.1 debian/lunzip/usr/share/man/man1/lzip.decompressor.1
+
+ ln -s /usr/bin/lzip.decompressor debian/lunzip/usr/bin/lunzip
+ ln -s /usr/share/man/man1/lzip.decompressor.1.gz debian/lunzip/usr/share/man/man1/lunzip.1.gz
override_dh_builddeb:
dh_builddeb -- -Zxz
+
+override_dh_strip:
+ dh_strip --dbg-package=lunzip-dbg