summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 5f3d9a7..66d4e2d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,8 +6,15 @@
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lunzip
-override_dh_strip:
- dh_strip --dbg-package=lunzip-dbg
+ # alernative handling
+ mv debian/lunzip/usr/bin/lunzip debian/lunzip/usr/bin/lzip.decompressor
+ mv debian/lunzip/usr/share/man/man1/lunzip.1 debian/lunzip/usr/share/man/man1/lzip.decompressor.1
+
+ ln -s /usr/bin/lzip.decompressor debian/lunzip/usr/bin/lunzip
+ ln -s /usr/share/man/man1/lzip.decompressor.1.gz debian/lunzip/usr/share/man/man1/lunzip.1.gz
override_dh_builddeb:
dh_builddeb -- -Zxz
+
+override_dh_strip:
+ dh_strip --dbg-package=lunzip-dbg