summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2016-06-08 16:33:37 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2016-06-08 16:34:01 +0000
commite60ddc10d5e26d8e4d5d092c7ac874ec6124737b (patch)
treeb303cbba36f2fd3cb52e729d56ea05f612def44c
parentReleasing debian version 0.8-1. (diff)
downloadlzd-e60ddc10d5e26d8e4d5d092c7ac874ec6124737b.tar.xz
lzd-e60ddc10d5e26d8e4d5d092c7ac874ec6124737b.zip
Merging upstream version 0.9.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--ChangeLog5
-rw-r--r--INSTALL2
-rw-r--r--Makefile.in9
-rw-r--r--NEWS6
-rwxr-xr-xconfigure6
-rw-r--r--lzd.cc12
-rwxr-xr-xtestsuite/check.sh2
7 files changed, 30 insertions, 12 deletions
diff --git a/ChangeLog b/ChangeLog
index 3aaf64a..c7c931f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2016-05-10 Antonio Diaz Diaz <antonio@gnu.org>
+
+ * Version 0.9 released.
+ * configure: Avoid warning on some shells when testing for g++.
+
2016-01-23 Antonio Diaz Diaz <antonio@gnu.org>
* Version 0.8 released.
diff --git a/INSTALL b/INSTALL
index 014ab3f..dc2e623 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,7 +1,7 @@
Requirements
------------
You will need a C++ compiler.
-I use gcc 4.9.1 and 4.1.2, but the code should compile with any
+I use gcc 5.3.0 and 4.1.2, but the code should compile with any
standards compliant compiler.
Gcc is available at http://gcc.gnu.org.
diff --git a/Makefile.in b/Makefile.in
index b125b52..42cdcc0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -5,6 +5,7 @@ INSTALL_PROGRAM = $(INSTALL) -m 755
INSTALL_DATA = $(INSTALL) -m 644
INSTALL_DIR = $(INSTALL) -d -m 755
SHELL = /bin/sh
+CAN_RUN_INSTALLINFO = $(SHELL) -c "install-info --version" > /dev/null 2>&1
objs = lzd.o
@@ -61,7 +62,9 @@ install-info :
if [ ! -d "$(DESTDIR)$(infodir)" ] ; then $(INSTALL_DIR) "$(DESTDIR)$(infodir)" ; fi
-rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
$(INSTALL_DATA) $(VPATH)/doc/$(pkgname).info "$(DESTDIR)$(infodir)/$(pkgname).info"
- -install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$(pkgname).info"
+ -if $(CAN_RUN_INSTALLINFO) ; then \
+ install-info --info-dir="$(DESTDIR)$(infodir)" "$(DESTDIR)$(infodir)/$(pkgname).info" ; \
+ fi
install-info-compress : install-info
lzip -v -9 "$(DESTDIR)$(infodir)/$(pkgname).info"
@@ -80,7 +83,9 @@ uninstall-bin :
-rm -f "$(DESTDIR)$(bindir)/$(progname)"
uninstall-info :
- -install-info --info-dir="$(DESTDIR)$(infodir)" --remove "$(DESTDIR)$(infodir)/$(pkgname).info"
+ -if $(CAN_RUN_INSTALLINFO) ; then \
+ install-info --info-dir="$(DESTDIR)$(infodir)" --remove "$(DESTDIR)$(infodir)/$(pkgname).info" ; \
+ fi
-rm -f "$(DESTDIR)$(infodir)/$(pkgname).info"*
uninstall-man :
diff --git a/NEWS b/NEWS
index 57ca1b3..085da72 100644
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Changes in version 0.8:
+Changes in version 0.9:
-It has been documented that lzip does not use the LZMA parameter
-'literal_pos_state_bits'.
+A configure warning happening on some shells when testing for g++ has
+been fixed.
diff --git a/configure b/configure
index 83d3447..226e838 100755
--- a/configure
+++ b/configure
@@ -6,7 +6,7 @@
# to copy, distribute and modify it.
pkgname=lzd
-pkgversion=0.8
+pkgversion=0.9
progname=lzd
srctrigger=lzd.cc
@@ -26,8 +26,8 @@ CXXFLAGS='-Wall -W -O2'
LDFLAGS=
# checking whether we are using GNU C++.
-${CXX} --version > /dev/null 2>&1
-if [ $? != 0 ] ; then
+if /bin/sh -c "${CXX} --version" > /dev/null 2>&1 ; then true
+else
CXX=c++
CXXFLAGS='-W -O2'
fi
diff --git a/lzd.cc b/lzd.cc
index 5f8dcdc..56dce37 100644
--- a/lzd.cc
+++ b/lzd.cc
@@ -1,8 +1,16 @@
/* Lzd - Educational decompressor for the lzip format
Copyright (C) 2013-2016 Antonio Diaz Diaz.
- This program is free software: you have unlimited permission
- to copy, distribute and modify it.
+ This program is free software. Redistribution and use in source and
+ binary forms, with or without modification, are permitted provided
+ that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
diff --git a/testsuite/check.sh b/testsuite/check.sh
index 7ebec69..f03377f 100755
--- a/testsuite/check.sh
+++ b/testsuite/check.sh
@@ -19,7 +19,7 @@ fi
if [ -d tmp ] ; then rm -rf tmp ; fi
mkdir tmp
-cd "${objdir}"/tmp
+cd "${objdir}"/tmp || framework_failure
in="${testdir}"/test.txt
in_lz="${testdir}"/test.txt.lz