summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-06-14 09:22:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-06-14 09:22:19 +0000
commit5ea0d875394cf03d121fb43b75d9beab07a38242 (patch)
treea9ea23e1bac74d31e3752cf65c19b78e4e2a5e99 /debian/rules
parentDropping using help2man. (diff)
downloadlzd-5ea0d875394cf03d121fb43b75d9beab07a38242.tar.xz
lzd-5ea0d875394cf03d121fb43b75d9beab07a38242.zip
Adding patch from Helmut Grohne <helmut@subdivi.de> to improve cross building by using the host compiler (Closes: #959521).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7350f30..1315012 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,13 @@
#!/usr/bin/make -f
+-include /usr/share/dpkg/buildtools.mk
+
%:
dh ${@}
+override_dh_auto_configure:
+ dh_auto_configure -- 'CXX=$(CXX)'
+
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/lzd