summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 10:21:14 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 10:21:14 +0000
commit1cb1a86779f89f0c629e21a0ae36f8b68b271edb (patch)
tree3fd92bfc8e5cf610589fdf3b8ff3efa944cc0281
parentMerging upstream version 1.14~rc1. (diff)
downloadlziprecover-1cb1a86779f89f0c629e21a0ae36f8b68b271edb.tar.xz
lziprecover-1cb1a86779f89f0c629e21a0ae36f8b68b271edb.zip
Adding debian version 1.14~rc1-1.debian/1.14_rc1-1
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--debian/changelog13
-rw-r--r--debian/control2
-rw-r--r--debian/copyright6
-rw-r--r--debian/lziprecover.postinst25
-rw-r--r--debian/lziprecover.prerm22
-rw-r--r--debian/patches/0001-build.patch (renamed from debian/patches/01-build.patch)12
-rw-r--r--debian/patches/0002-format-security.patch24
-rw-r--r--debian/patches/series3
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/source/options1
10 files changed, 106 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 3729d72..5b52c48 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+lziprecover (1.14~rc1-1) experimental; urgency=low
+
+ * Merging upstream version 1.14~rc1.
+ * Updating years in copyright file.
+ * Dropping dpkg-source compression levels.
+ * Prefixing patches with four digits.
+ * Trimming diff headers in patches.
+ * Refreshing build.patch.
+ * Using string literal to fix FTBFS with -Werror=format-security.
+ * Adding alternative handling for /usr/bin/lzip.
+
+ -- Daniel Baumann <mail@daniel-baumann.ch> Mon, 25 Mar 2013 19:37:20 +0100
+
lziprecover (1.13-4) unstable; urgency=low
* Removing all references to my old email address.
diff --git a/debian/control b/debian/control
index e66b7f4..edff4ad 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Homepage: http://www.nongnu.org/lzip/lziprecover.html
Package: lziprecover
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
-Conflicts: lzip (<< 1.13~rc1-1~)
+Breaks: lzip (<< 1.15~)
Description: lossless data compressor based on the LZMA algorithm (recovery)
Lzip is a lossless data compressor based on the LZMA algorithm, with very safe
integrity checking and a user interface similar to the one of gzip or bzip2.
diff --git a/debian/copyright b/debian/copyright
index 5e2182f..5aae980 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -4,15 +4,15 @@ Upstream-Contact: lzip-bug@nongnu.org
Source: http://download.savannah.gnu.org/releases/lzip/
Files: *
-Copyright: 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
+Copyright: 2006-2013 Antonio Diaz Diaz <ant_diaz@teleline.es>
License: GPL-3+
Files: arg_parser.*
-Copyright: 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
+Copyright: 2006-2013 Antonio Diaz Diaz <ant_diaz@teleline.es>
License: GPL-3+ with Library exception
Files: debian/*
-Copyright: 2011-2012 Daniel Baumann <mail@daniel-baumann.ch>
+Copyright: 2011-2013 Daniel Baumann <mail@daniel-baumann.ch>
License: GPL-3+
License: GPL-3+
diff --git a/debian/lziprecover.postinst b/debian/lziprecover.postinst
new file mode 100644
index 0000000..cb73f75
--- /dev/null
+++ b/debian/lziprecover.postinst
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ configure)
+ update-alternatives --quiet \
+ --install /usr/bin/lzip lzip /usr/bin/lzip.recover 50 \
+ --slave /usr/share/info/lzip.info.gz lzip.info.gz /usr/share/info/lzip.recover.info.gz \
+ --slave /usr/share/man/man1/lzip.1.gz lzip.1.gz /usr/share/man/man1/lzip.recover.1.gz
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/lziprecover.prerm b/debian/lziprecover.prerm
new file mode 100644
index 0000000..f8e7f39
--- /dev/null
+++ b/debian/lziprecover.prerm
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ remove|upgrade|deconfigure)
+ update-alternatives --quiet --remove lzip /usr/bin/lzip.recover
+ ;;
+
+ failed-upgrade)
+
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/patches/01-build.patch b/debian/patches/0001-build.patch
index d9862e5..42a9dce 100644
--- a/debian/patches/01-build.patch
+++ b/debian/patches/0001-build.patch
@@ -1,13 +1,13 @@
Author: Daniel Baumann <mail@daniel-baumann.ch>
Description: Avoid overwriting build-environment.
-diff -Naurp lzip.orig/configure lzip/configure
---- lzip.orig/configure 2012-06-30 00:54:43.926501688 +0200
-+++ lzip/configure 2012-06-30 00:55:57.423296881 +0200
+diff -Naurp lziprecover.orig/configure lziprecover/configure
+--- lziprecover.orig/configure
++++ lziprecover/configure
@@ -23,9 +23,9 @@ datarootdir='$(prefix)/share'
infodir='$(datarootdir)/info'
mandir='$(datarootdir)/man'
- CXX=
+ CXX=g++
-CPPFLAGS=
-CXXFLAGS='-Wall -W -O2'
-LDFLAGS=
@@ -15,5 +15,5 @@ diff -Naurp lzip.orig/configure lzip/configure
+#CXXFLAGS='-Wall -W -O2'
+#LDFLAGS=
- # Loop over all args
- while [ -n "$1" ] ; do
+ # checking whether we are using GNU C++.
+ if [ ! -x /bin/g++ ] &&
diff --git a/debian/patches/0002-format-security.patch b/debian/patches/0002-format-security.patch
new file mode 100644
index 0000000..ac9a3c9
--- /dev/null
+++ b/debian/patches/0002-format-security.patch
@@ -0,0 +1,24 @@
+Author: Daniel Baumann <mail@daniel-baumann.ch>
+Description: Using string literal to fix FTBFS with -Werror=format-security.
+
+diff -Naurp lziprecover.orig/main.cc lziprecover/main.cc
+--- lziprecover.orig/main.cc
++++ lziprecover/main.cc
+@@ -418,7 +418,7 @@ int decompress( const int infd, const Pr
+ }
+ retval = 2; break;
+ }
+- if( verbosity >= 2 ) { std::fprintf( stderr, ok_msg ); pp.reset(); }
++ if( verbosity >= 2 ) { std::fprintf( stderr, "%s", ok_msg ); pp.reset(); }
+ }
+ }
+ catch( std::bad_alloc )
+@@ -427,7 +427,7 @@ int decompress( const int infd, const Pr
+ retval = 1;
+ }
+ catch( Error e ) { pp(); show_error( e.msg, errno ); retval = 1; }
+- if( verbosity == 1 && retval == 0 ) std::fprintf( stderr, ok_msg );
++ if( verbosity == 1 && retval == 0 ) std::fprintf( stderr, "%s", ok_msg );
+ return retval;
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index 605653d..86cb98b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
-01-build.patch
+0001-build.patch
+0002-format-security.patch
diff --git a/debian/rules b/debian/rules
index 45a2f60..6820b21 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,8 +9,17 @@ override_dh_auto_install:
# removing unused files
rm -f debian/lziprecover/usr/share/info/dir*
+ # alernative handling
+ mv debian/lziprecover/usr/bin/lziprecover debian/lziprecover/usr/bin/lzip.recover
+ mv debian/lziprecover/usr/share/info/lziprecover.info debian/lziprecover/usr/share/info/lzip.recover.info
+ mv debian/lziprecover/usr/share/man/man1/lziprecover.1 debian/lziprecover/usr/share/man/man1/lzip.recover.1
+
+ ln -s /usr/bin/lzip.recover debian/lziprecover/usr/bin/lziprecover
+ ln -s /usr/share/info/lzip.recover.info.gz debian/lziprecover/usr/share/info/lziprecover.info.gz
+ ln -s /usr/share/man/man1/lzip.recover.1.gz debian/lziprecover/usr/share/man/man1/lziprecover.1.gz
+
override_dh_strip:
dh_strip --dbg-package=lziprecover-dbg
override_dh_builddeb:
- dh_builddeb -- -Zxz -z9
+ dh_builddeb -- -Zxz
diff --git a/debian/source/options b/debian/source/options
index 22a4de9..5bd47b7 100644
--- a/debian/source/options
+++ b/debian/source/options
@@ -1,2 +1 @@
compression = xz
-compression-level = 9