summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian-no-Werror.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-24 14:37:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-24 14:37:52 +0000
commit1cbda917747b894268cbe6ec6e576db26d9fd049 (patch)
treec88de9d39f187cf339e1add1f768bbda4a61130f /debian/patches/debian-no-Werror.diff
parentAdding upstream version 4.2. (diff)
downloadmdadm-1cbda917747b894268cbe6ec6e576db26d9fd049.tar.xz
mdadm-1cbda917747b894268cbe6ec6e576db26d9fd049.zip
Adding debian version 4.2-5.debian/4.2-5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/debian-no-Werror.diff')
-rw-r--r--debian/patches/debian-no-Werror.diff24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/debian-no-Werror.diff b/debian/patches/debian-no-Werror.diff
new file mode 100644
index 0000000..371df52
--- /dev/null
+++ b/debian/patches/debian-no-Werror.diff
@@ -0,0 +1,24 @@
+From: martin f. krafft <madduck@debian.org>
+Subject: Remove -Werror from compiler flags
+
+-Werror seems like a bad idea on released/packaged code because a toolchain
+update (introducing new warnings) could break the build. We'll let upstream
+use it to beautify the code, but remove it for out builds.
+
+Signed-off-by: martin f. krafft <madduck@debian.org>
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+--- a/Makefile
++++ b/Makefile
+@@ -50,7 +50,7 @@ ifeq ($(origin CC),default)
+ CC := $(CROSS_COMPILE)gcc
+ endif
+ CXFLAGS ?= -ggdb
+-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
++CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
+ ifdef WARN_UNUSED
+ CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
+ endif