diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2021-03-08 06:39:52 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2021-03-08 06:39:52 +0000 |
commit | f96615a770febe0d511ad79d17169aca58095bf2 (patch) | |
tree | 60c586dcee842be1b061221a5fb454a153857585 /setup.py | |
parent | Adding upstream version 1.23.2. (diff) | |
download | mycli-f96615a770febe0d511ad79d17169aca58095bf2.tar.xz mycli-f96615a770febe0d511ad79d17169aca58095bf2.zip |
Adding upstream version 1.24.1.upstream/1.24.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 6 insertions, 2 deletions
@@ -18,16 +18,20 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight install_requirements = [ 'click >= 7.0', + 'cryptography >= 1.0.0', 'Pygments >= 1.6', 'prompt_toolkit>=3.0.6,<4.0.0', 'PyMySQL >= 0.9.2', 'sqlparse>=0.3.0,<0.4.0', 'configobj >= 5.0.5', - 'cryptography >= 1.0.0', 'cli_helpers[styles] >= 2.0.1', - 'pyperclip >= 1.8.1' + 'pyperclip >= 1.8.1', + 'pyaes >= 1.6.1' ] +if sys.version_info.minor < 9: + install_requirements.append('importlib_resources >= 5.0.0') + class lint(Command): description = 'check code against PEP 8 (and fix violations)' |