summaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-12-15 19:36:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-12-15 19:36:42 +0000
commitcb225b2c0e816db4f3a913ee323580c6108f2dce (patch)
tree3fbc1877ef0405bc04863d901c71171bf06db6db /tox.ini
parentReleasing debian version 1.28.0-2. (diff)
downloadmycli-cb225b2c0e816db4f3a913ee323580c6108f2dce.tar.xz
mycli-cb225b2c0e816db4f3a913ee323580c6108f2dce.zip
Merging upstream version 1.29.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tox.ini20
1 files changed, 13 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index 612e8b7..f4228f2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,15 +1,21 @@
[tox]
-envlist = py36, py37, py38
+envlist = py
[testenv]
-deps = pytest
- mock
- pexpect
- behave
- coverage
-commands = python setup.py test
+skip_install = true
+deps = uv
passenv = PYTEST_HOST
PYTEST_USER
PYTEST_PASSWORD
PYTEST_PORT
PYTEST_CHARSET
+commands = uv pip install -e .[dev,ssh]
+ coverage run -m pytest -v test
+ coverage report -m
+ behave test/features
+
+[testenv:style]
+skip_install = true
+deps = ruff
+commands = ruff check --fix
+ ruff format