summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-25 14:36:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-11-25 17:34:10 +0000
commit35a7497ade7456d6e9e589fd4feb631693524f55 (patch)
treeb89f011c1c54cd06a084c49c2fdd115b28f0e083
parentMerging upstream version 2.0.3+dfsg (Closes: #923993, #1042533, #1045145). (diff)
downloadnetdata-35a7497ade7456d6e9e589fd4feb631693524f55.tar.xz
netdata-35a7497ade7456d6e9e589fd4feb631693524f55.zip
Adding upstream target in rules.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e13c9a2c7..262844fa6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+VERSION := $(shell dpkg-parsechangelog | awk '/^Version: / { print $$2 }' | cut -d+ -f1)
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/architecture.mk
@@ -110,3 +112,19 @@ override_dh_fixperms-indep:
chmod 0644 debian/netdata-plugins-bash/usr/libexec/netdata/charts.d/*.sh
chmod 0644 debian/netdata-plugins-bash/usr/libexec/netdata/plugins.d/*.sh.inc
chmod 0644 debian/netdata-plugins-python/usr/libexec/netdata/python.d/*.py
+
+upstream:
+ git clone --recursive https://github.com/netdata/netdata netdata-$(VERSION)+dfsg
+ cd netdata-$(VERSION)+dfsg && git checkout -f v$(VERSION)
+
+ # removing embedded python modules
+ rm -rf netdata-$(VERSION)+dfsg/src/collectors/python.d.plugin/python_modules/pyyaml3
+ rm -rf netdata-$(VERSION)+dfsg/src/collectors/python.d.plugin/python_modules/third_party
+ rm -rf netdata-$(VERSION)+dfsg/src/collectors/python.d.plugin/python_modules/urllib3
+
+ # removing embedded shared libraries
+ rm -rf netdata-$(VERSION)+dfsg/src/ml/dlib
+ rm -rf netdata-$(VERSION)+dfsg/src/web/server/h2o/libh2o
+
+ # removing git metadata
+ rm -rf netdata-$(VERSION)+dfsg/.git