summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2018-04-04 12:36:53 +0000
committerLennart Weller <lhw@ring0.de>2018-04-04 12:36:53 +0000
commit6b3cef56dd710063d07a02972810a4ef83124541 (patch)
tree5e32537d6ac00d236360069329979df6db3afa81
parentAdd set -eu (diff)
downloadnetdata-6b3cef56dd710063d07a02972810a4ef83124541.tar.xz
netdata-6b3cef56dd710063d07a02972810a4ef83124541.zip
updated patches for 1.10
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch151
-rw-r--r--debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch86
-rw-r--r--debian/patches/0003-hide-update-button.patch4
-rw-r--r--debian/patches/0004-Debianize-path-to-exim4-binary.patch6
-rw-r--r--debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch9
-rw-r--r--debian/patches/series1
6 files changed, 64 insertions, 193 deletions
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
index 45c5cf5ba..c2ad8f661 100644
--- a/debian/patches/0001-python-libraries-removed-from-make.patch
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -1,59 +1,21 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Mon, 18 Sep 2017 13:05:36 +0200
-Subject: python libraries removed from make remove unused contrib files
- remove linked web files
+Date: Wed, 4 Apr 2018 14:22:34 +0200
+Subject: python libraries removed from make. remove unused contrib files
---
- contrib/Makefile.am | 30 ---------------
- python.d/Makefile.am | 107 ---------------------------------------------------
- web/Makefile.am | 32 ---------------
- 3 files changed, 169 deletions(-)
+ python.d/Makefile.am | 42 --------------------------------
+ python.d/python_modules/bases/loaders.py | 4 +--
+ web/Makefile.am | 32 ------------------------
+ 3 files changed, 2 insertions(+), 76 deletions(-)
-diff --git a/contrib/Makefile.am b/contrib/Makefile.am
-index 15e9c00..5df6933 100644
---- a/contrib/Makefile.am
-+++ b/contrib/Makefile.am
-@@ -1,31 +1 @@
- MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
--
--dist_noinst_DATA = \
-- README.md \
-- debian/copyright \
-- debian/netdata.conf \
-- debian/source/format \
-- debian/control.wheezy \
-- debian/compat \
-- debian/netdata.install \
-- debian/netdata.lintian-overrides \
-- debian/rules \
-- debian/netdata.docs \
-- debian/netdata.default \
-- debian/control \
-- debian/netdata.postinst.in \
-- debian/netdata.service \
-- debian/changelog \
-- debian/netdata.postrm \
-- $(NULL)
--
--dist_noinst_SCRIPTS = \
-- debian/netdata.init \
-- nc-backend.sh \
-- $(NULL)
--
--debian/changelog:
-- echo "netdata ($(PACKAGE_VERSION)) UNRELEASED; urgency=medium" | \
-- tr '_' '~' > $@
-- echo " * Latest release" >> $@
-- echo " -- Netdata Team <> `date -R`" >> $@
diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index 1c84cdd..63c2c04 100644
+index a5fcc73..29d8c45 100644
--- a/python.d/Makefile.am
+++ b/python.d/Makefile.am
-@@ -88,110 +88,3 @@ dist_third_party_DATA = \
- python_modules/third_party/ordereddict.py \
+@@ -97,48 +97,6 @@ dist_third_party_DATA = \
python_modules/third_party/lm_sensors.py \
$(NULL)
--
+
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
-dist_pythonyaml2_DATA = \
- python_modules/pyyaml2/__init__.py \
@@ -96,72 +58,29 @@ index 1c84cdd..63c2c04 100644
- python_modules/pyyaml3/tokens.py \
- $(NULL)
-
--python_urllib3dir=$(pythonmodulesdir)/urllib3
--dist_python_urllib3_DATA = \
-- python_modules/urllib3/__init__.py \
-- python_modules/urllib3/_collections.py \
-- python_modules/urllib3/connection.py \
-- python_modules/urllib3/connectionpool.py \
-- python_modules/urllib3/exceptions.py \
-- python_modules/urllib3/fields.py \
-- python_modules/urllib3/filepost.py \
-- python_modules/urllib3/response.py \
-- python_modules/urllib3/poolmanager.py \
-- python_modules/urllib3/request.py \
-- $(NULL)
--
--python_urllib3_utildir=$(python_urllib3dir)/util
--dist_python_urllib3_util_DATA = \
-- python_modules/urllib3/util/__init__.py \
-- python_modules/urllib3/util/connection.py \
-- python_modules/urllib3/util/request.py \
-- python_modules/urllib3/util/response.py \
-- python_modules/urllib3/util/retry.py \
-- python_modules/urllib3/util/selectors.py \
-- python_modules/urllib3/util/ssl_.py \
-- python_modules/urllib3/util/timeout.py \
-- python_modules/urllib3/util/url.py \
-- python_modules/urllib3/util/wait.py \
-- $(NULL)
--
--python_urllib3_packagesdir=$(python_urllib3dir)/packages
--dist_python_urllib3_packages_DATA = \
-- python_modules/urllib3/packages/__init__.py \
-- python_modules/urllib3/packages/ordered_dict.py \
-- python_modules/urllib3/packages/six.py \
-- $(NULL)
--
--python_urllib3_backportsdir=$(python_urllib3_packagesdir)/backports
--dist_python_urllib3_backports_DATA = \
-- python_modules/urllib3/packages/backports/__init__.py \
-- python_modules/urllib3/packages/backports/makefile.py \
-- $(NULL)
--
--python_urllib3_ssl_match_hostnamedir=$(python_urllib3_packagesdir)/ssl_match_hostname
--dist_python_urllib3_ssl_match_hostname_DATA = \
-- python_modules/urllib3/packages/ssl_match_hostname/__init__.py \
-- python_modules/urllib3/packages/ssl_match_hostname/_implementation.py \
-- $(NULL)
--
--python_urllib3_contribdir=$(python_urllib3dir)/contrib
--dist_python_urllib3_contrib_DATA = \
-- python_modules/urllib3/contrib/__init__.py \
-- python_modules/urllib3/contrib/appengine.py \
-- python_modules/urllib3/contrib/ntlmpool.py \
-- python_modules/urllib3/contrib/pyopenssl.py \
-- python_modules/urllib3/contrib/securetransport.py \
-- python_modules/urllib3/contrib/socks.py \
-- $(NULL)
--
--python_urllib3_securetransportdir=$(python_urllib3_contribdir)/_securetransport
--dist_python_urllib3_securetransport_DATA = \
-- python_modules/urllib3/contrib/_securetransport/__init__.py \
-- python_modules/urllib3/contrib/_securetransport/bindings.py \
-- python_modules/urllib3/contrib/_securetransport/low_level.py \
-- $(NULL)
--
+ python_urllib3dir=$(pythonmodulesdir)/urllib3
+ dist_python_urllib3_DATA = \
+ python_modules/urllib3/__init__.py \
+diff --git a/python.d/python_modules/bases/loaders.py b/python.d/python_modules/bases/loaders.py
+index d18b9dc..71ba221 100644
+--- a/python.d/python_modules/bases/loaders.py
++++ b/python.d/python_modules/bases/loaders.py
+@@ -8,11 +8,11 @@ from sys import version_info
+ PY_VERSION = version_info[:2]
+
+ if PY_VERSION > (3, 1):
+- from pyyaml3 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ from importlib.machinery import SourceFileLoader
+ DEFAULT_MAPPING_TAG = 'tag:yaml.org,2002:map'
+ else:
+- from pyyaml2 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ from imp import load_source as SourceFileLoader
+ DEFAULT_MAPPING_TAG = u'tag:yaml.org,2002:map'
+
diff --git a/web/Makefile.am b/web/Makefile.am
-index 02d8931..38e8f48 100644
+index ac92287..57595fc 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -4,10 +4,6 @@
@@ -175,7 +94,7 @@ index 02d8931..38e8f48 100644
dashboard.html \
dashboard.js \
dashboard_info.js \
-@@ -27,15 +23,6 @@ dist_web_DATA = \
+@@ -28,15 +24,6 @@ dist_web_DATA = \
version.txt \
$(NULL)
@@ -191,8 +110,8 @@ index 02d8931..38e8f48 100644
weblibdir=$(webdir)/lib
dist_weblib_DATA = \
lib/bootstrap-3.3.7.min.js \
-@@ -72,15 +59,6 @@ dist_webcss_DATA = \
- css/c3-0.4.11.min.css \
+@@ -75,15 +62,6 @@ dist_webcss_DATA = \
+ css/c3-0.4.18.min.css \
$(NULL)
-webfontsdir=$(webdir)/fonts
@@ -207,7 +126,7 @@ index 02d8931..38e8f48 100644
webimagesdir=$(webdir)/images
dist_webimages_DATA = \
images/alert-128-orange.png \
-@@ -105,16 +83,6 @@ dist_webimages_DATA = \
+@@ -108,16 +86,6 @@ dist_webimages_DATA = \
images/seo-performance-multi-size.icns \
$(NULL)
diff --git a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
index 3832543bb..e2e163781 100644
--- a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
+++ b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
@@ -1,79 +1,21 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Mon, 18 Sep 2017 13:09:35 +0200
+Date: Wed, 4 Apr 2018 14:25:03 +0200
Subject: remove file serve restrictions for symlinks
---
- src/web_client.c | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
+ src/web_client.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+diff --git a/src/web_client.c b/src/web_client.c
+index 477fb3d..38ebf47 100644
--- a/src/web_client.c
+++ b/src/web_client.c
-@@ -382,8 +382,8 @@
- snprintfz(webfilename, FILENAME_MAX, "%s/%s", netdata_configured_web_dir, filename);
-
- // check if the file exists
-- struct stat stat;
-- if(lstat(webfilename, &stat) != 0) {
-+ struct stat wstat;
-+ if(stat(webfilename, &wstat) != 0) {
- debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
- w->response.data->contenttype = CT_TEXT_HTML;
- buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");
-@@ -392,8 +392,8 @@
- }
-
- // check if the file is owned by expected user
-- if(stat.st_uid != web_files_uid()) {
-- error("%llu: File '%s' is owned by user %u (expected user %u). Access Denied.", w->id, webfilename, stat.st_uid, web_files_uid());
-+ if(wstat.st_uid != web_files_uid()) {
-+ error("%llu: File '%s' is owned by user %u (expected user %u). Access Denied.", w->id, webfilename, wstat.st_uid, web_files_uid());
- w->response.data->contenttype = CT_TEXT_HTML;
- buffer_strcat(w->response.data, "Access to file is not permitted: ");
- buffer_strcat_htmlescape(w->response.data, webfilename);
-@@ -401,20 +401,20 @@
- }
-
- // check if the file is owned by expected group
-- if(stat.st_gid != web_files_gid()) {
-- error("%llu: File '%s' is owned by group %u (expected group %u). Access Denied.", w->id, webfilename, stat.st_gid, web_files_gid());
-+ if(wstat.st_gid != web_files_gid()) {
-+ error("%llu: File '%s' is owned by group %u (expected group %u). Access Denied.", w->id, webfilename, wstat.st_gid, web_files_gid());
- w->response.data->contenttype = CT_TEXT_HTML;
- buffer_strcat(w->response.data, "Access to file is not permitted: ");
- buffer_strcat_htmlescape(w->response.data, webfilename);
- return 403;
- }
-
-- if((stat.st_mode & S_IFMT) == S_IFDIR) {
-+ if((wstat.st_mode & S_IFMT) == S_IFDIR) {
- snprintfz(webfilename, FILENAME_MAX, "%s/index.html", filename);
- return mysendfile(w, webfilename);
- }
-
-- if((stat.st_mode & S_IFMT) != S_IFREG) {
-+ if((wstat.st_mode & S_IFMT) != S_IFREG) {
- error("%llu: File '%s' is not a regular file. Access Denied.", w->id, webfilename);
- w->response.data->contenttype = CT_TEXT_HTML;
- buffer_strcat(w->response.data, "Access to file is not permitted: ");
-@@ -468,17 +468,17 @@
- else if(strstr(filename, ".icns") != NULL) w->response.data->contenttype = CT_IMAGE_ICNS;
- else w->response.data->contenttype = CT_APPLICATION_OCTET_STREAM;
-
-- debug(D_WEB_CLIENT_ACCESS, "%llu: Sending file '%s' (%ld bytes, ifd %d, ofd %d).", w->id, webfilename, stat.st_size, w->ifd, w->ofd);
-+ debug(D_WEB_CLIENT_ACCESS, "%llu: Sending file '%s' (%ld bytes, ifd %d, ofd %d).", w->id, webfilename, wstat.st_size, w->ifd, w->ofd);
-
- w->mode = WEB_CLIENT_MODE_FILECOPY;
- web_client_enable_wait_receive(w);
- web_client_disable_wait_send(w);
- buffer_flush(w->response.data);
-- w->response.rlen = stat.st_size;
-+ w->response.rlen = wstat.st_size;
- #ifdef __APPLE__
-- w->response.data->date = stat.st_mtimespec.tv_sec;
-+ w->response.data->date = wstat.st_mtimespec.tv_sec;
- #else
-- w->response.data->date = stat.st_mtim.tv_sec;
-+ w->response.data->date = wstat.st_mtim.tv_sec;
- #endif /* __APPLE__ */
- buffer_cacheable(w->response.data);
-
+@@ -362,7 +362,7 @@ int mysendfile(struct web_client *w, char *filename) {
+ int done = 0;
+ while(!done) {
+ // check if the file exists
+- if (lstat(webfilename, &statbuf) != 0) {
++ if (stat(webfilename, &statbuf) != 0) {
+ debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
+ w->response.data->contenttype = CT_TEXT_HTML;
+ buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");
diff --git a/debian/patches/0003-hide-update-button.patch b/debian/patches/0003-hide-update-button.patch
index 0b33cb62b..0f66a8175 100644
--- a/debian/patches/0003-hide-update-button.patch
+++ b/debian/patches/0003-hide-update-button.patch
@@ -1,11 +1,13 @@
From: Federico Ceratto <federico.ceratto@gmail.com>
-Date: Mon, 18 Sep 2017 13:10:09 +0200
+Date: Wed, 4 Apr 2018 14:26:21 +0200
Subject: hide update button
---
web/index.html | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
+diff --git a/web/index.html b/web/index.html
+index ea146fc..bc7964c 100644
--- a/web/index.html
+++ b/web/index.html
@@ -4522,7 +4522,7 @@
diff --git a/debian/patches/0004-Debianize-path-to-exim4-binary.patch b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
index 6e9960fb7..7c60db312 100644
--- a/debian/patches/0004-Debianize-path-to-exim4-binary.patch
+++ b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
@@ -1,14 +1,16 @@
From: Sven Hartge <sven@svenhartge.de>
-Date: Mon, 18 Sep 2017 13:11:05 +0200
+Date: Wed, 4 Apr 2018 14:26:50 +0200
Subject: Debianize path to exim4 binary
---
conf.d/python.d/exim.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
+diff --git a/conf.d/python.d/exim.conf b/conf.d/python.d/exim.conf
+index 2add7b2..dd36a00 100644
--- a/conf.d/python.d/exim.conf
+++ b/conf.d/python.d/exim.conf
-@@ -90,4 +90,4 @@
+@@ -90,4 +90,4 @@ update_every: 10
# AUTO-DETECTION JOBS
local:
diff --git a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
index cf9a2fe19..0e623cf0d 100644
--- a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
+++ b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
@@ -1,5 +1,5 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Mon, 18 Sep 2017 13:11:30 +0200
+Date: Wed, 4 Apr 2018 14:27:27 +0200
Subject: remove infographic for privacy breach reasons
---
@@ -8,9 +8,11 @@ Subject: remove infographic for privacy breach reasons
2 files changed, 171 deletions(-)
delete mode 100644 web/infographic.html
+diff --git a/web/Makefile.am b/web/Makefile.am
+index 57595fc..6564740 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
-@@ -13,7 +13,6 @@
+@@ -13,7 +13,6 @@ dist_web_DATA = \
favicon.ico \
goto-host-from-alarm.html \
index.html \
@@ -18,6 +20,9 @@ Subject: remove infographic for privacy breach reasons
netdata-swagger.yaml \
netdata-swagger.json \
robots.txt \
+diff --git a/web/infographic.html b/web/infographic.html
+deleted file mode 100644
+index 0bb5718..0000000
--- a/web/infographic.html
+++ /dev/null
@@ -1,170 +0,0 @@
diff --git a/debian/patches/series b/debian/patches/series
index 1bacc64f2..7c4a6f2ba 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,5 @@
0001-python-libraries-removed-from-make.patch
+0002-remove-file-serve-restrictions-for-symlinks.patch
0003-hide-update-button.patch
0004-Debianize-path-to-exim4-binary.patch
0005-remove-infographic-for-privacy-breach-reasons.patch