summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 17:17:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-03 17:20:51 +0000
commit415724bb2d3b0d32bf4b732ba5d3ad8879f6b8ba (patch)
treeb3d0b641880cb665890f600a84d20611df0fad49
parentComplementing previous changelog entry about new upstream release. (diff)
downloadnetdata-415724bb2d3b0d32bf4b732ba5d3ad8879f6b8ba.tar.xz
netdata-415724bb2d3b0d32bf4b732ba5d3ad8879f6b8ba.zip
Updating moving of architecture independet plugins to fix FTBFS when building arch-indep packages only.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ecb35e663..bff9ea87c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -74,14 +74,14 @@ ifeq (netdata-core-no-sse,$(findstring netdata-core-no-sse,$(PACKAGES)))
dh_auto_install -B build-core-no-sse -- DESTDIR=$(CURDIR)/debian/tmp-core-no-sse
endif
-override_dh_install-arch:
- find debian/tmp -name .keep -delete
-
# Moving architecture independent plugins
mkdir -p $(TOP)-plugins-python/usr/lib/netdata/conf.d/health.d
mv debian/tmp/usr/lib/netdata/conf.d/health.d/mongodb.conf $(TOP)-plugins-python/usr/lib/netdata/conf.d/health.d
mv debian/tmp/usr/lib/netdata/conf.d/mongodb.conf $(TOP)-plugins-python/usr/lib/netdata/conf.d
+override_dh_install-arch:
+ find debian/tmp -name .keep -delete
+
# Copy architecture dependent plugins
mkdir -p $(TOP)-core/etc/netdata
cp debian/local/netdata/netdata.conf $(TOP)-core/etc/netdata