summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2017-01-27 11:03:23 +0000
committerLennart Weller <lhw@ring0.de>2017-01-28 17:37:58 +0000
commited65f20a658fc2f71cfcb334df49f7bd5d440af8 (patch)
treea61b1c8f50d01340b798ccbb4a9b6dae0c56dcde
parentupdated changelog (diff)
downloadnetdata-ed65f20a658fc2f71cfcb334df49f7bd5d440af8.tar.xz
netdata-ed65f20a658fc2f71cfcb334df49f7bd5d440af8.zip
fixed python modules not loading
-rw-r--r--debian/control4
-rw-r--r--debian/netdata.install1
-rw-r--r--debian/patches/0001-linked-js-css-fonts-removed-from-make.patch22
-rw-r--r--debian/patches/0004-use-system-python-yaml-library.patch33
-rw-r--r--debian/patches/series1
5 files changed, 44 insertions, 17 deletions
diff --git a/debian/control b/debian/control
index 77098b6fb..bfc623f76 100644
--- a/debian/control
+++ b/debian/control
@@ -24,8 +24,8 @@ Depends: adduser,
libjs-bootstrap,
lsb-base (>= 3.1-23.2),
netdata-data (=${source:Version}),
- python3,
- python3-yaml,
+ python,
+ python-yaml,
${misc:Depends},
${misc:Pre-Depends},
${shlibs:Depends}
diff --git a/debian/netdata.install b/debian/netdata.install
index 07124d3f4..a5f9aaeae 100644
--- a/debian/netdata.install
+++ b/debian/netdata.install
@@ -6,3 +6,4 @@ usr/lib/*/netdata/plugins.d/*.plugin
usr/lib/*/netdata/plugins.d/*.sh
usr/lib/*/netdata/plugins.d/loopsleepms.sh.inc
usr/lib/*/netdata/python.d/*.py
+usr/lib/*/netdata/python.d/python_modules
diff --git a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch b/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
index eb3e93cd8..db0f99b8c 100644
--- a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
+++ b/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
@@ -1,29 +1,21 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Thu, 26 Jan 2017 14:03:06 +0100
+Date: Sat, 28 Jan 2017 17:57:59 +0100
Subject: linked js/css/fonts removed from make
---
- python.d/Makefile.am | 50 --------------------------------------------------
+ python.d/Makefile.am | 42 ------------------------------------------
web/Makefile.am | 35 -----------------------------------
- 2 files changed, 85 deletions(-)
+ 2 files changed, 77 deletions(-)
diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index 883f06c..f8b14da 100644
+index 883f06c..a163fe7 100644
--- a/python.d/Makefile.am
+++ b/python.d/Makefile.am
-@@ -45,53 +45,3 @@ dist_python_SCRIPTS = \
- dist_python_DATA = \
- README.md \
+@@ -53,45 +53,3 @@ dist_pythonmodules_DATA = \
+ python_modules/msg.py \
+ python_modules/lm_sensors.py \
$(NULL)
-
--pythonmodulesdir=$(pythondir)/python_modules
--dist_pythonmodules_DATA = \
-- python_modules/__init__.py \
-- python_modules/base.py \
-- python_modules/msg.py \
-- python_modules/lm_sensors.py \
-- $(NULL)
--
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
-dist_pythonyaml2_DATA = \
- python_modules/pyyaml2/__init__.py \
diff --git a/debian/patches/0004-use-system-python-yaml-library.patch b/debian/patches/0004-use-system-python-yaml-library.patch
new file mode 100644
index 000000000..c4a0912b0
--- /dev/null
+++ b/debian/patches/0004-use-system-python-yaml-library.patch
@@ -0,0 +1,33 @@
+From: Lennart Weller <lhw@ring0.de>
+Date: Sat, 28 Jan 2017 18:34:35 +0100
+Subject: use system python-yaml library
+
+---
+ plugins.d/python.d.plugin | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/plugins.d/python.d.plugin b/plugins.d/python.d.plugin
+index b4e6473..867fe5b 100755
+--- a/plugins.d/python.d.plugin
++++ b/plugins.d/python.d.plugin
+@@ -55,19 +55,11 @@ except (AssertionError, ImportError):
+ msg.info('Using python v2')
+ except ImportError:
+ msg.fatal('Cannot start. No importlib.machinery on python3 or lack of imp on python2')
+-# try:
+-# import yaml
+-# except ImportError:
+-# msg.fatal('Cannot find yaml library')
+ try:
+- if PY_VERSION == 3:
+- import pyyaml3 as yaml
+- else:
+- import pyyaml2 as yaml
++ import yaml
+ except ImportError:
+ msg.fatal('Cannot find yaml library')
+
+-
+ class PythonCharts(object):
+ """
+ Main class used to control every python module.
diff --git a/debian/patches/series b/debian/patches/series
index 8e008db19..0eade4cfd 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0001-linked-js-css-fonts-removed-from-make.patch
0002-remove-file-serve-restrictions-for-symlinks.patch
0003-hide-update-button.patch
+0004-use-system-python-yaml-library.patch