summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 13:56:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 13:56:22 +0000
commit8bd49e7f153f6109ff1a5199ec9cdd638cbd43ce (patch)
tree40683031009c2fc144477a6378cc4abfcbe518cf
parentHarmonizing patch numbering. (diff)
downloadnetdata-8bd49e7f153f6109ff1a5199ec9cdd638cbd43ce.tar.xz
netdata-8bd49e7f153f6109ff1a5199ec9cdd638cbd43ce.zip
Minimizing use-system-python.patch.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/patches/debian/0001-use-system-python.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/patches/debian/0001-use-system-python.patch b/debian/patches/debian/0001-use-system-python.patch
index 6f649cf12..5a14159d5 100644
--- a/debian/patches/debian/0001-use-system-python.patch
+++ b/debian/patches/debian/0001-use-system-python.patch
@@ -117,15 +117,15 @@ diff -Naurp netdata.orig/collectors/python.d.plugin/Makefile.am netdata/collecto
diff -Naurp netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
--- netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders.py
+++ netdata/collectors/python.d.plugin/python_modules/bases/loaders.py
-@@ -10,9 +10,9 @@ PY_VERSION = version_info[:2]
+@@ -9,10 +9,7 @@ from sys import version_info
+ PY_VERSION = version_info[:2]
try:
- if PY_VERSION > (3, 1):
+- if PY_VERSION > (3, 1):
- from pyyaml3 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- else:
+- else:
- from pyyaml2 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
except ImportError:
from yaml import SafeLoader as YamlSafeLoader