summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2018-12-31 07:44:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2018-12-31 07:44:35 +0000
commit0b06b0a11b4fad8d81c7307a2cbf9042ce92023c (patch)
tree9d3c4c64cc140a5a5cf0a07e3909df9e4cf78c4b
parentWriting exact version number into netdata itself. (diff)
downloadnetdata-0b06b0a11b4fad8d81c7307a2cbf9042ce92023c.tar.xz
netdata-0b06b0a11b4fad8d81c7307a2cbf9042ce92023c.zip
Preserving unmodified configure.ac during builds to not fail to build twice in a row (workaround for #728029).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5c321d1f..e2456ae7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,9 @@ MULTIARCH_INSTALL = debian/netdata.postinst
dh $@
override_dh_autoreconf:
+ rm -f debian/configure.ac.orig
+ cp configure.ac debian/configure.ac.orig
+
sed -i -e 's/^\(define(\[VERSION_MAJOR]\).*/\1, [$(VERSION_MAJOR)])/' \
-e 's/^\(define(\[VERSION_MINOR]\).*/\1, [$(VERSION_MINOR)])/' \
-e 's/^\(define(\[VERSION_FIX]\).*/\1, [$(VERSION_FIX)])/' \
@@ -31,6 +34,15 @@ override_dh_autoreconf:
dh_autoreconf
+override_dh_autoreconf_clean:
+ if [ -e debian/configure.ac.orig ]; \
+ then \
+ rm -f configure.ac; \
+ mv debian/configure.ac.orig configure.ac; \
+ fi
+
+ dh_autoreconf_clean
+
override_dh_auto_configure:
dh_auto_configure -- --libexecdir=/usr/lib/$(DEB_HOST_MULTIARCH) --with-math