summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2017-09-18 11:16:22 +0000
committerLennart Weller <lhw@ring0.de>2017-09-18 11:31:44 +0000
commit1031a445dd6f19a1bf5d10fffa649f321f6d0fcc (patch)
tree41b15779153ee99dacd23f4b52848ab5ed9e2bd0
parentchangelog (diff)
downloadnetdata-1031a445dd6f19a1bf5d10fffa649f321f6d0fcc.tar.xz
netdata-1031a445dd6f19a1bf5d10fffa649f321f6d0fcc.zip
updated patches. added extra python dependency
-rw-r--r--debian/changelog2
-rw-r--r--debian/control3
-rw-r--r--debian/copyright3
-rw-r--r--debian/netdata.maintscript4
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch (renamed from debian/patches/0001-linked-js-css-fonts-removed-from-make.patch)79
-rw-r--r--debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch16
-rw-r--r--debian/patches/0003-hide-update-button.patch6
-rw-r--r--debian/patches/0004-Debianize-path-to-exim4-binary.patch (renamed from debian/patches/0006-fix-exim-path.patch)2
-rw-r--r--debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch (renamed from debian/patches/0006-remove-infographic-for-privacy-breach-reasons.patch)2
-rw-r--r--debian/patches/0006-use-system-python-yaml-library.patch (renamed from debian/patches/0004-use-system-python-yaml-library.patch)2
-rw-r--r--debian/patches/series8
11 files changed, 96 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index 93ae793ec..dc3e647cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-netdata (187.0+dfsg-1) UNRELEASED; urgency=medium
+netdata (1.8.0+dfsg-1) UNRELEASED; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index b242dade8..fd83343cb 100644
--- a/debian/control
+++ b/debian/control
@@ -22,11 +22,12 @@ Depends: adduser,
lsb-base (>= 3.1-23.2),
netdata-data (=${source:Version}),
python,
+ python-urllib3,
python-yaml,
${misc:Depends},
${misc:Pre-Depends},
${shlibs:Depends}
-Recommends: nodejs, fping, curl
+Recommends: curl, fping, nodejs
Description: real-time charts for system monitoring
Netdata is a daemon that collects data in realtime (per second)
and presents a web site to view and analyze them. The presentation
diff --git a/debian/copyright b/debian/copyright
index 34a9ed5fb..3613f8eec 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -30,8 +30,7 @@ Copyright: 2004 Free Software Foundation Inc.
License: LGPL-3+
Files:
- node.d/node_modules/ber/*
- node.d/node_modules/asn1.js
+ node.d/node_modules/lib/ber/*
Copyright: 2011 Mark Cavage <mcavage@gmail.com>
License: Expat
diff --git a/debian/netdata.maintscript b/debian/netdata.maintscript
index 9ef6a69ed..521755a0d 100644
--- a/debian/netdata.maintscript
+++ b/debian/netdata.maintscript
@@ -1,2 +1,2 @@
-rm_conffile /etc/netdata/python.d/nginx_log.conf 1.7.0+dfsg-2~ netdata
-rm_conffile /etc/netdata/python.d/gunicorn_log.conf 1.7.0+dfsg-2~ netdata
+rm_conffile /etc/netdata/python.d/nginx_log.conf 1.8.0+dfsg-1~ netdata
+rm_conffile /etc/netdata/python.d/gunicorn_log.conf 1.8.0+dfsg-1~ netdata
diff --git a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
index 238424dd9..cb13ac23a 100644
--- a/debian/patches/0001-linked-js-css-fonts-removed-from-make.patch
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -1,17 +1,17 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Sat, 28 Jan 2017 17:57:59 +0100
-Subject: linked js/css/fonts removed from make
+Date: Mon, 18 Sep 2017 13:05:36 +0200
+Subject: python libraries removed from make
---
- python.d/Makefile.am | 42 ------------------------------------------
- web/Makefile.am | 35 -----------------------------------
- 2 files changed, 77 deletions(-)
+ python.d/Makefile.am | 107 ---------------------------------------------------
+ web/Makefile.am | 35 -----------------
+ 2 files changed, 142 deletions(-)
diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index 43f25cf..2931a48 100644
+index 84c2aea..2996a53 100644
--- a/python.d/Makefile.am
+++ b/python.d/Makefile.am
-@@ -59,45 +59,3 @@ dist_pythonmodules_DATA = \
+@@ -60,110 +60,3 @@ dist_pythonmodules_DATA = \
python_modules/msg.py \
python_modules/lm_sensors.py \
$(NULL)
@@ -57,6 +57,71 @@ index 43f25cf..2931a48 100644
- python_modules/pyyaml3/serializer.py \
- python_modules/pyyaml3/tokens.py \
- $(NULL)
+-
+-python_urllib3dir=$(pythonmodulesdir)/urllib3
+-dist_python_urllib3_DATA = \
+- python_modules/urllib3/__init__.py \
+- python_modules/urllib3/_collections.py \
+- python_modules/urllib3/connection.py \
+- python_modules/urllib3/connectionpool.py \
+- python_modules/urllib3/exceptions.py \
+- python_modules/urllib3/fields.py \
+- python_modules/urllib3/filepost.py \
+- python_modules/urllib3/response.py \
+- python_modules/urllib3/poolmanager.py \
+- python_modules/urllib3/request.py \
+- $(NULL)
+-
+-python_urllib3_utildir=$(python_urllib3dir)/util
+-dist_python_urllib3_util_DATA = \
+- python_modules/urllib3/util/__init__.py \
+- python_modules/urllib3/util/connection.py \
+- python_modules/urllib3/util/request.py \
+- python_modules/urllib3/util/response.py \
+- python_modules/urllib3/util/retry.py \
+- python_modules/urllib3/util/selectors.py \
+- python_modules/urllib3/util/ssl_.py \
+- python_modules/urllib3/util/timeout.py \
+- python_modules/urllib3/util/url.py \
+- python_modules/urllib3/util/wait.py \
+- $(NULL)
+-
+-python_urllib3_packagesdir=$(python_urllib3dir)/packages
+-dist_python_urllib3_packages_DATA = \
+- python_modules/urllib3/packages/__init__.py \
+- python_modules/urllib3/packages/ordered_dict.py \
+- python_modules/urllib3/packages/six.py \
+- $(NULL)
+-
+-python_urllib3_backportsdir=$(python_urllib3_packagesdir)/backports
+-dist_python_urllib3_backports_DATA = \
+- python_modules/urllib3/packages/backports/__init__.py \
+- python_modules/urllib3/packages/backports/makefile.py \
+- $(NULL)
+-
+-python_urllib3_ssl_match_hostnamedir=$(python_urllib3_packagesdir)/ssl_match_hostname
+-dist_python_urllib3_ssl_match_hostname_DATA = \
+- python_modules/urllib3/packages/ssl_match_hostname/__init__.py \
+- python_modules/urllib3/packages/ssl_match_hostname/_implementation.py \
+- $(NULL)
+-
+-python_urllib3_contribdir=$(python_urllib3dir)/contrib
+-dist_python_urllib3_contrib_DATA = \
+- python_modules/urllib3/contrib/__init__.py \
+- python_modules/urllib3/contrib/appengine.py \
+- python_modules/urllib3/contrib/ntlmpool.py \
+- python_modules/urllib3/contrib/pyopenssl.py \
+- python_modules/urllib3/contrib/securetransport.py \
+- python_modules/urllib3/contrib/socks.py \
+- $(NULL)
+-
+-python_urllib3_securetransportdir=$(python_urllib3_contribdir)/_securetransport
+-dist_python_urllib3_securetransport_DATA = \
+- python_modules/urllib3/contrib/_securetransport/__init__.py \
+- python_modules/urllib3/contrib/_securetransport/bindings.py \
+- python_modules/urllib3/contrib/_securetransport/low_level.py \
+- $(NULL)
+-
diff --git a/web/Makefile.am b/web/Makefile.am
index b587f5a..9f33500 100644
--- a/web/Makefile.am
diff --git a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
index 8ecff89bb..b1a40b40b 100644
--- a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
+++ b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
@@ -1,5 +1,5 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Tue, 24 Jan 2017 16:48:19 +0100
+Date: Mon, 18 Sep 2017 13:09:35 +0200
Subject: remove file serve restrictions for symlinks
---
@@ -7,10 +7,10 @@ Subject: remove file serve restrictions for symlinks
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/src/web_client.c b/src/web_client.c
-index 7da0807..4e1e8fb 100644
+index 6ec3e11..6d30205 100644
--- a/src/web_client.c
+++ b/src/web_client.c
-@@ -294,8 +294,8 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -303,8 +303,8 @@ int mysendfile(struct web_client *w, char *filename) {
snprintfz(webfilename, FILENAME_MAX, "%s/%s", netdata_configured_web_dir, filename);
// check if the file exists
@@ -21,7 +21,7 @@ index 7da0807..4e1e8fb 100644
debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");
-@@ -304,8 +304,8 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -313,8 +313,8 @@ int mysendfile(struct web_client *w, char *filename) {
}
// check if the file is owned by expected user
@@ -32,7 +32,7 @@ index 7da0807..4e1e8fb 100644
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "Access to file is not permitted: ");
buffer_strcat_htmlescape(w->response.data, webfilename);
-@@ -313,20 +313,20 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -322,20 +322,20 @@ int mysendfile(struct web_client *w, char *filename) {
}
// check if the file is owned by expected group
@@ -57,7 +57,7 @@ index 7da0807..4e1e8fb 100644
error("%llu: File '%s' is not a regular file. Access Denied.", w->id, webfilename);
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "Access to file is not permitted: ");
-@@ -380,17 +380,17 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -389,17 +389,17 @@ int mysendfile(struct web_client *w, char *filename) {
else if(strstr(filename, ".icns") != NULL) w->response.data->contenttype = CT_IMAGE_ICNS;
else w->response.data->contenttype = CT_APPLICATION_OCTET_STREAM;
@@ -65,8 +65,8 @@ index 7da0807..4e1e8fb 100644
+ debug(D_WEB_CLIENT_ACCESS, "%llu: Sending file '%s' (%ld bytes, ifd %d, ofd %d).", w->id, webfilename, wstat.st_size, w->ifd, w->ofd);
w->mode = WEB_CLIENT_MODE_FILECOPY;
- w->wait_receive = 1;
- w->wait_send = 0;
+ web_client_enable_wait_receive(w);
+ web_client_disable_wait_send(w);
buffer_flush(w->response.data);
- w->response.rlen = stat.st_size;
+ w->response.rlen = wstat.st_size;
diff --git a/debian/patches/0003-hide-update-button.patch b/debian/patches/0003-hide-update-button.patch
index a3d9258f0..33697ea67 100644
--- a/debian/patches/0003-hide-update-button.patch
+++ b/debian/patches/0003-hide-update-button.patch
@@ -1,5 +1,5 @@
From: Federico Ceratto <federico.ceratto@gmail.com>
-Date: Tue, 24 Jan 2017 16:48:45 +0100
+Date: Mon, 18 Sep 2017 13:10:09 +0200
Subject: hide update button
---
@@ -7,10 +7,10 @@ Subject: hide update button
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/web/index.html b/web/index.html
-index be944e3..7bbae2f 100644
+index cd8239d..57d6a75 100644
--- a/web/index.html
+++ b/web/index.html
-@@ -3025,7 +3025,7 @@
+@@ -3033,7 +3033,7 @@
<ul class="nav navbar-nav">
<li><a href="#" class="btn" data-toggle="modal" data-target="#alarmsModal" title="alarms"><i class="fa fa-bell"></i>&nbsp;<span class="hidden-sm">Alarms&nbsp;</span><span id="alarms_count_badge" class="badge"></span></a></li>
<li><a href="#" class="btn" data-toggle="modal" data-target="#optionsModal" title="dashboard settings"><i class="fa fa-sliders"></i>&nbsp;<span class="hidden-sm">Settings</span></a></li>
diff --git a/debian/patches/0006-fix-exim-path.patch b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
index c92baddb6..34556a4f0 100644
--- a/debian/patches/0006-fix-exim-path.patch
+++ b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
@@ -1,5 +1,5 @@
From: Sven Hartge <sven@svenhartge.de>
-Date: Sun, 26 Feb 2017 23:57:41 +0100
+Date: Mon, 18 Sep 2017 13:11:05 +0200
Subject: Debianize path to exim4 binary
---
diff --git a/debian/patches/0006-remove-infographic-for-privacy-breach-reasons.patch b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
index 466411834..a580aee58 100644
--- a/debian/patches/0006-remove-infographic-for-privacy-breach-reasons.patch
+++ b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
@@ -1,5 +1,5 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Thu, 27 Jul 2017 12:38:32 +0200
+Date: Mon, 18 Sep 2017 13:11:30 +0200
Subject: remove infographic for privacy breach reasons
---
diff --git a/debian/patches/0004-use-system-python-yaml-library.patch b/debian/patches/0006-use-system-python-yaml-library.patch
index 378685289..ab08fc56d 100644
--- a/debian/patches/0004-use-system-python-yaml-library.patch
+++ b/debian/patches/0006-use-system-python-yaml-library.patch
@@ -1,5 +1,5 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Sat, 28 Jan 2017 18:34:35 +0100
+Date: Mon, 18 Sep 2017 13:19:18 +0200
Subject: use system python-yaml library
---
diff --git a/debian/patches/series b/debian/patches/series
index 430e3c228..835ace226 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,6 @@
-0001-linked-js-css-fonts-removed-from-make.patch
+0001-python-libraries-removed-from-make.patch
0002-remove-file-serve-restrictions-for-symlinks.patch
0003-hide-update-button.patch
-0004-use-system-python-yaml-library.patch
-0006-fix-exim-path.patch
-0006-remove-infographic-for-privacy-breach-reasons.patch
+0004-Debianize-path-to-exim4-binary.patch
+0005-remove-infographic-for-privacy-breach-reasons.patch
+0006-use-system-python-yaml-library.patch