summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennart Weller <lhw@ring0.de>2018-11-14 13:44:48 +0000
committerLennart Weller <lhw@ring0.de>2018-11-14 13:44:48 +0000
commit1f484d2a2bc8632ed1e894e6330065cd971cdf88 (patch)
tree5f13effd3d231c21f247ea4d602558b8f08944e5
parentUpdate debian/watch pattern (diff)
downloadnetdata-1f484d2a2bc8632ed1e894e6330065cd971cdf88.tar.xz
netdata-1f484d2a2bc8632ed1e894e6330065cd971cdf88.zip
Updated patches for 1.11
- kfreebsd/hurd build is not available right now
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch86
-rw-r--r--debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch14
-rw-r--r--debian/patches/0003-hide-update-button.patch16
-rw-r--r--debian/patches/0004-Debianize-path-to-exim4-binary.patch14
-rw-r--r--debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch35
-rw-r--r--debian/patches/0006-Force-usage-of-python3.patch23
-rw-r--r--debian/patches/0007-Skip-debian-files-in-upstream-s-makefile.patch41
-rw-r--r--debian/patches/0007-python-config-directory.patch18
-rw-r--r--debian/patches/0008-force-python3.patch17
-rw-r--r--debian/patches/0009-debian-files-removed-from-make.patch33
-rw-r--r--debian/patches/compile-on-kfreebsd-hurd.patch.unused (renamed from debian/patches/0006-compile-on-kfreebsd-hurd.patch)0
-rw-r--r--debian/patches/series6
12 files changed, 140 insertions, 163 deletions
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
index ed5b314f8..d49036c8a 100644
--- a/debian/patches/0001-python-libraries-removed-from-make.patch
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -1,20 +1,20 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Wed, 4 Apr 2018 14:22:34 +0200
+Date: Wed, 14 Nov 2018 14:21:40 +0100
Subject: python libraries removed from make. remove unused contrib files
---
- python.d/Makefile.am | 106 -------------------------------
- python.d/python_modules/bases/loaders.py | 4 +-
- web/Makefile.am | 32 ----------
- 3 files changed, 2 insertions(+), 140 deletions(-)
+ collectors/python.d.plugin/Makefile.am | 106 ---------------------
+ .../python_modules/bases/loaders.py | 4 +-
+ web/gui/Makefile.am | 23 -----
+ 3 files changed, 2 insertions(+), 131 deletions(-)
-diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index a5fcc73..3349ccf 100644
---- a/python.d/Makefile.am
-+++ b/python.d/Makefile.am
-@@ -96,109 +96,3 @@ dist_third_party_DATA = \
- python_modules/third_party/ordereddict.py \
- python_modules/third_party/lm_sensors.py \
+diff --git a/collectors/python.d.plugin/Makefile.am b/collectors/python.d.plugin/Makefile.am
+index 5f214e4..79c9dc3 100644
+--- a/collectors/python.d.plugin/Makefile.am
++++ b/collectors/python.d.plugin/Makefile.am
+@@ -136,109 +136,3 @@ dist_third_party_DATA = \
+ python_modules/third_party/boinc_client.py \
+ python_modules/third_party/monotonic.py \
$(NULL)
-
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
@@ -122,30 +122,28 @@ index a5fcc73..3349ccf 100644
- python_modules/urllib3/contrib/_securetransport/bindings.py \
- python_modules/urllib3/contrib/_securetransport/low_level.py \
- $(NULL)
-diff --git a/python.d/python_modules/bases/loaders.py b/python.d/python_modules/bases/loaders.py
-index d18b9dc..71ba221 100644
---- a/python.d/python_modules/bases/loaders.py
-+++ b/python.d/python_modules/bases/loaders.py
-@@ -8,11 +8,11 @@ from sys import version_info
- PY_VERSION = version_info[:2]
+diff --git a/collectors/python.d.plugin/python_modules/bases/loaders.py b/collectors/python.d.plugin/python_modules/bases/loaders.py
+index 9eb268c..28c67d7 100644
+--- a/collectors/python.d.plugin/python_modules/bases/loaders.py
++++ b/collectors/python.d.plugin/python_modules/bases/loaders.py
+@@ -11,9 +11,9 @@ PY_VERSION = version_info[:2]
- if PY_VERSION > (3, 1):
-- from pyyaml3 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- from importlib.machinery import SourceFileLoader
- DEFAULT_MAPPING_TAG = 'tag:yaml.org,2002:map'
- else:
-- from pyyaml2 import SafeLoader as YamlSafeLoader
-+ from yaml import SafeLoader as YamlSafeLoader
- from imp import load_source as SourceFileLoader
- DEFAULT_MAPPING_TAG = u'tag:yaml.org,2002:map'
+ try:
+ if PY_VERSION > (3, 1):
+- from pyyaml3 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ else:
+- from pyyaml2 import SafeLoader as YamlSafeLoader
++ from yaml import SafeLoader as YamlSafeLoader
+ except ImportError:
+ from yaml import SafeLoader as YamlSafeLoader
-diff --git a/web/Makefile.am b/web/Makefile.am
-index ac92287..57595fc 100644
---- a/web/Makefile.am
-+++ b/web/Makefile.am
-@@ -4,10 +4,6 @@
- MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
+diff --git a/web/gui/Makefile.am b/web/gui/Makefile.am
+index 314ca37..2b6f124 100644
+--- a/web/gui/Makefile.am
++++ b/web/gui/Makefile.am
+@@ -9,10 +9,6 @@ dist_noinst_DATA = \
+ $(NULL)
dist_web_DATA = \
- demo.html \
@@ -155,23 +153,7 @@ index ac92287..57595fc 100644
dashboard.html \
dashboard.js \
dashboard_info.js \
-@@ -28,15 +24,6 @@ dist_web_DATA = \
- version.txt \
- $(NULL)
-
--webolddir=$(webdir)/old
--dist_webold_DATA = \
-- old/datasource.html \
-- old/index.html \
-- old/index.js \
-- old/netdata.js \
-- old/theme.css \
-- $(NULL)
--
- weblibdir=$(webdir)/lib
- dist_weblib_DATA = \
- lib/bootstrap-3.3.7.min.js \
-@@ -75,15 +62,6 @@ dist_webcss_DATA = \
+@@ -69,15 +65,6 @@ dist_webcss_DATA = \
css/c3-0.4.18.min.css \
$(NULL)
@@ -187,7 +169,7 @@ index ac92287..57595fc 100644
webimagesdir=$(webdir)/images
dist_webimages_DATA = \
images/alert-128-orange.png \
-@@ -108,16 +86,6 @@ dist_webimages_DATA = \
+@@ -103,16 +90,6 @@ dist_webimages_DATA = \
images/seo-performance-multi-size.icns \
$(NULL)
diff --git a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
index e2e163781..449524b6e 100644
--- a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
+++ b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
@@ -1,16 +1,16 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Wed, 4 Apr 2018 14:25:03 +0200
+Date: Wed, 14 Nov 2018 14:24:17 +0100
Subject: remove file serve restrictions for symlinks
---
- src/web_client.c | 2 +-
+ web/server/web_client.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/src/web_client.c b/src/web_client.c
-index 477fb3d..38ebf47 100644
---- a/src/web_client.c
-+++ b/src/web_client.c
-@@ -362,7 +362,7 @@ int mysendfile(struct web_client *w, char *filename) {
+diff --git a/web/server/web_client.c b/web/server/web_client.c
+index 282cfcd..eed6b59 100644
+--- a/web/server/web_client.c
++++ b/web/server/web_client.c
+@@ -372,7 +372,7 @@ int mysendfile(struct web_client *w, char *filename) {
int done = 0;
while(!done) {
// check if the file exists
diff --git a/debian/patches/0003-hide-update-button.patch b/debian/patches/0003-hide-update-button.patch
index 0f66a8175..f0ea1adb5 100644
--- a/debian/patches/0003-hide-update-button.patch
+++ b/debian/patches/0003-hide-update-button.patch
@@ -1,21 +1,21 @@
From: Federico Ceratto <federico.ceratto@gmail.com>
-Date: Wed, 4 Apr 2018 14:26:21 +0200
+Date: Wed, 14 Nov 2018 14:25:12 +0100
Subject: hide update button
---
- web/index.html | 2 +-
+ web/gui/index.html | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/web/index.html b/web/index.html
-index ea146fc..bc7964c 100644
---- a/web/index.html
-+++ b/web/index.html
-@@ -4522,7 +4522,7 @@
+diff --git a/web/gui/index.html b/web/gui/index.html
+index 0a01b1d..bdeecfc 100644
+--- a/web/gui/index.html
++++ b/web/gui/index.html
+@@ -4582,7 +4582,7 @@
<ul class="nav navbar-nav">
<li id="alarmsButton" title="check the health monitoring alarms and their log" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#alarmsModal"><i class="fas fa-bell"></i>&nbsp;<span class="hidden-sm hidden-md">Alarms&nbsp;</span><span id="alarms_count_badge" class="badge"></span></a></li>
<li title="change dashboard settings" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#optionsModal"><i class="fas fa-cog"></i>&nbsp;<span class="hidden-sm hidden-md">Settings</span></a></li>
- <li title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
+ <li style="display: none;" title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
- <li title="the netdata wiki home at github<br/>remember to <b>give netdata a <i class=&quot;fas fa-star&quot;></i></b> !" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://github.com/firehol/netdata/wiki" class="btn" target="_blank"><i class="fab fa-github"></i></a></li>
+ <li title="the netdata wiki home at github<br/>remember to <b>give netdata a <i class=&quot;fas fa-star&quot;></i></b> !" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://github.com/netdata/netdata/wiki" class="btn" target="_blank"><i class="fab fa-github"></i></a></li>
<li title="follow netdata on twitter" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://twitter.com/linuxnetdata" class="btn" target="_blank"><i class="fab fa-twitter"></i></a></li>
<li title="like netdata on facebook" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://www.facebook.com/linuxnetdata/" class="btn" target="_blank"><i class="fab fa-facebook"></i></a></li>
diff --git a/debian/patches/0004-Debianize-path-to-exim4-binary.patch b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
index 7c60db312..7d34e7618 100644
--- a/debian/patches/0004-Debianize-path-to-exim4-binary.patch
+++ b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
@@ -1,18 +1,18 @@
From: Sven Hartge <sven@svenhartge.de>
-Date: Wed, 4 Apr 2018 14:26:50 +0200
+Date: Wed, 14 Nov 2018 14:28:21 +0100
Subject: Debianize path to exim4 binary
---
- conf.d/python.d/exim.conf | 2 +-
+ collectors/python.d.plugin/exim/exim.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/conf.d/python.d/exim.conf b/conf.d/python.d/exim.conf
-index 2add7b2..dd36a00 100644
---- a/conf.d/python.d/exim.conf
-+++ b/conf.d/python.d/exim.conf
+diff --git a/collectors/python.d.plugin/exim/exim.conf b/collectors/python.d.plugin/exim/exim.conf
+index 2add7b2..053689b 100644
+--- a/collectors/python.d.plugin/exim/exim.conf
++++ b/collectors/python.d.plugin/exim/exim.conf
@@ -90,4 +90,4 @@ update_every: 10
# AUTO-DETECTION JOBS
local:
- command: 'exim -bpc'
-+ command: '/usr/sbin/exim4 -bpc'
++ command: '/usr/sbin/exim -bpc'
diff --git a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
index 0e623cf0d..faeb135bd 100644
--- a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
+++ b/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
@@ -1,32 +1,33 @@
From: Lennart Weller <lhw@ring0.de>
-Date: Wed, 4 Apr 2018 14:27:27 +0200
+Date: Wed, 14 Nov 2018 14:29:21 +0100
Subject: remove infographic for privacy breach reasons
---
- web/Makefile.am | 1 -
- web/infographic.html | 170 ---------------------------------------------------
- 2 files changed, 171 deletions(-)
- delete mode 100644 web/infographic.html
+ web/gui/Makefile.am | 1 -
+ web/gui/infographic.html | 171 -----------------------------------------------
+ 2 files changed, 172 deletions(-)
+ delete mode 100644 web/gui/infographic.html
-diff --git a/web/Makefile.am b/web/Makefile.am
-index 57595fc..6564740 100644
---- a/web/Makefile.am
-+++ b/web/Makefile.am
-@@ -13,7 +13,6 @@ dist_web_DATA = \
+diff --git a/web/gui/Makefile.am b/web/gui/Makefile.am
+index 2b6f124..42a2779 100644
+--- a/web/gui/Makefile.am
++++ b/web/gui/Makefile.am
+@@ -18,7 +18,6 @@ dist_web_DATA = \
favicon.ico \
goto-host-from-alarm.html \
index.html \
- infographic.html \
- netdata-swagger.yaml \
- netdata-swagger.json \
robots.txt \
-diff --git a/web/infographic.html b/web/infographic.html
+ refresh-badges.js \
+ registry.html \
+diff --git a/web/gui/infographic.html b/web/gui/infographic.html
deleted file mode 100644
-index 0bb5718..0000000
---- a/web/infographic.html
+index b311278..0000000
+--- a/web/gui/infographic.html
+++ /dev/null
-@@ -1,170 +0,0 @@
+@@ -1,171 +0,0 @@
-<!doctype html>
+-<!-- SPDX-License-Identifier: GPL-3.0-or-later -->
-<html lang=en-us>
-<head>
- <meta charset=utf-8>
@@ -192,7 +193,7 @@ index 0bb5718..0000000
- }(document, 'script', 'facebook-jssdk'));
-</script>
-
--<script type="text/javascript" src="https://www.draw.io/embed2.js?s=arrows2;mscae/cloud;azure;office/users;office/servers&fetch=https%3A%2F%2Fraw.githubusercontent.com%2Ffirehol%2Fnetdata%2Fmaster%2Fdiagrams%2Fnetdata-overview.xml"></script>
+-<script type="text/javascript" src="https://www.draw.io/embed2.js?s=arrows2;mscae/cloud;azure;office/users;office/servers&fetch=https%3A%2F%2Fraw.githubusercontent.com%2Fnetdata%2Fnetdata%2Fmaster%2Fdiagrams%2Fnetdata-overview.xml"></script>
-
-</html>
-
diff --git a/debian/patches/0006-Force-usage-of-python3.patch b/debian/patches/0006-Force-usage-of-python3.patch
new file mode 100644
index 000000000..eed4e4c38
--- /dev/null
+++ b/debian/patches/0006-Force-usage-of-python3.patch
@@ -0,0 +1,23 @@
+From: Sander Klein <debian-bugs@roedie.nl>
+Date: Wed, 14 Nov 2018 14:36:37 +0100
+Subject: Force usage of python3
+
+ Debian uses Python2 by default. The netdata package installs the
+ Python3 dependencies. So, in order to work correctly it must use
+ Python3.
+---
+ collectors/python.d.plugin/python.d.plugin | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/collectors/python.d.plugin/python.d.plugin b/collectors/python.d.plugin/python.d.plugin
+index 264c338..9437405 100644
+--- a/collectors/python.d.plugin/python.d.plugin
++++ b/collectors/python.d.plugin/python.d.plugin
+@@ -1,6 +1,4 @@
+-#!/usr/bin/env bash
+-'''':; exec "$(command -v python || command -v python3 || command -v python2 ||
+-echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
++#!/usr/bin/python3
+
+ # -*- coding: utf-8 -*-
+ # Description:
diff --git a/debian/patches/0007-Skip-debian-files-in-upstream-s-makefile.patch b/debian/patches/0007-Skip-debian-files-in-upstream-s-makefile.patch
new file mode 100644
index 000000000..6edc7b7ba
--- /dev/null
+++ b/debian/patches/0007-Skip-debian-files-in-upstream-s-makefile.patch
@@ -0,0 +1,41 @@
+From: Daniel Baumann <daniel.baumann@progress-linux.org>
+Date: Wed, 14 Nov 2018 14:38:22 +0100
+Subject: Skip debian files in upstream's makefile.
+
+---
+ contrib/Makefile.am | 19 -------------------
+ 1 file changed, 19 deletions(-)
+
+diff --git a/contrib/Makefile.am b/contrib/Makefile.am
+index 80d80d3..cff936f 100644
+--- a/contrib/Makefile.am
++++ b/contrib/Makefile.am
+@@ -4,28 +4,9 @@ MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+ dist_noinst_DATA = \
+ README.md \
+- debian/copyright \
+- debian/netdata.conf \
+- debian/source/format \
+- debian/control.wheezy \
+- debian/compat \
+- debian/netdata.install \
+- debian/netdata.lintian-overrides \
+- debian/rules \
+- debian/netdata.docs \
+- debian/netdata.default \
+- debian/control \
+- debian/netdata.postinst.in \
+- debian/netdata.service \
+- debian/changelog \
+- debian/netdata.postrm \
+ rhel/build-netdata-rpm.sh \
+ $(NULL)
+
+-dist_noinst_SCRIPTS = \
+- debian/netdata.init \
+- $(NULL)
+-
+ debian/changelog:
+ echo "netdata ($(PACKAGE_VERSION)) UNRELEASED; urgency=medium" | \
+ tr '_' '~' > $@
diff --git a/debian/patches/0007-python-config-directory.patch b/debian/patches/0007-python-config-directory.patch
deleted file mode 100644
index 2ca355af4..000000000
--- a/debian/patches/0007-python-config-directory.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Author: Sander Klein <debian-bugs@roedie.nl>
-Description:
- Since the config is expected to be located in /etc/netdata it is kind
- of silly to use ../../../../ to get to the right path. Moreover it
- breaks netdata on Debian.
-
-diff -Naurp netdata.orig/plugins.d/python.d.plugin netdata/plugins.d/python.d.plugin
---- netdata.orig/plugins.d/python.d.plugin
-+++ netdata/plugins.d/python.d.plugin
-@@ -21,7 +21,7 @@ except ImportError:
- from time import time
-
- PY_VERSION = version_info[:2]
--PLUGIN_CONFIG_DIR = os.getenv('NETDATA_CONFIG_DIR', os.path.dirname(__file__) + '/../../../../etc/netdata') + '/'
-+PLUGIN_CONFIG_DIR = os.getenv('NETDATA_CONFIG_DIR', '/etc/netdata') + '/'
- CHARTS_PY_DIR = os.path.abspath(os.getenv('NETDATA_PLUGINS_DIR', os.path.dirname(__file__)) + '/../python.d') + '/'
- CHARTS_PY_CONFIG_DIR = PLUGIN_CONFIG_DIR + 'python.d/'
- PYTHON_MODULES_DIR = CHARTS_PY_DIR + 'python_modules'
diff --git a/debian/patches/0008-force-python3.patch b/debian/patches/0008-force-python3.patch
deleted file mode 100644
index fb92e42ed..000000000
--- a/debian/patches/0008-force-python3.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Author: Sander Klein <debian-bugs@roedie.nl>
-Description: Force usage of python3
- Debian uses Python2 by default. The netdata package installs the
- Python3 dependencies. So, in order to work correctly it must use
- Python3.
-
-diff -Naurp netdata.orig/plugins.d/python.d.plugin netdata/plugins.d/python.d.plugin
---- netdata.orig/plugins.d/python.d.plugin
-+++ netdata/plugins.d/python.d.plugin
-@@ -1,6 +1,4 @@
--#!/usr/bin/env bash
--'''':; exec "$(command -v python || command -v python3 || command -v python2 ||
--echo "ERROR python IS NOT AVAILABLE IN THIS SYSTEM")" "$0" "$@" # '''
-+#!/usr/bin/python3
-
- # -*- coding: utf-8 -*-
- # Description:
diff --git a/debian/patches/0009-debian-files-removed-from-make.patch b/debian/patches/0009-debian-files-removed-from-make.patch
deleted file mode 100644
index 10102d78c..000000000
--- a/debian/patches/0009-debian-files-removed-from-make.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Author: Daniel Baumann <daniel.baumann@progress-linux.org>
-Description: Skip debian files in upstream's makefile.
-
-diff -Naurp netdata.orig/contrib/Makefile.am netdata/contrib/Makefile.am
---- netdata.orig/contrib/Makefile.am
-+++ netdata/contrib/Makefile.am
-@@ -2,26 +2,10 @@ MAINTAINERCLEANFILES= $(srcdir)/Makefile
-
- dist_noinst_DATA = \
- README.md \
-- debian/copyright \
-- debian/netdata.conf \
-- debian/source/format \
-- debian/control.wheezy \
-- debian/compat \
-- debian/netdata.install \
-- debian/netdata.lintian-overrides \
-- debian/rules \
-- debian/netdata.docs \
-- debian/netdata.default \
-- debian/control \
-- debian/netdata.postinst.in \
-- debian/netdata.service \
-- debian/changelog \
-- debian/netdata.postrm \
- rhel/build-netdata-rpm.sh \
- $(NULL)
-
- dist_noinst_SCRIPTS = \
-- debian/netdata.init \
- nc-backend.sh \
- $(NULL)
-
diff --git a/debian/patches/0006-compile-on-kfreebsd-hurd.patch b/debian/patches/compile-on-kfreebsd-hurd.patch.unused
index f2ba3f2a7..f2ba3f2a7 100644
--- a/debian/patches/0006-compile-on-kfreebsd-hurd.patch
+++ b/debian/patches/compile-on-kfreebsd-hurd.patch.unused
diff --git a/debian/patches/series b/debian/patches/series
index 79cfb2045..65526bf80 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,7 +3,5 @@
0003-hide-update-button.patch
0004-Debianize-path-to-exim4-binary.patch
0005-remove-infographic-for-privacy-breach-reasons.patch
-0006-compile-on-kfreebsd-hurd.patch
-0007-python-config-directory.patch
-0008-force-python3.patch
-0009-debian-files-removed-from-make.patch
+0006-Force-usage-of-python3.patch
+0007-Skip-debian-files-in-upstream-s-makefile.patch