summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Ceratto <federico.ceratto@gmail.com>2017-12-20 00:05:53 +0000
committerFederico Ceratto <federico.ceratto@gmail.com>2017-12-20 15:43:44 +0000
commit4eecd612b3275719f0101e890057d84fa7c4db9f (patch)
tree3b29e26a8be97e6766827bd3c40af19bd57fabc8
parentNew upstream release (diff)
downloadnetdata-4eecd612b3275719f0101e890057d84fa7c4db9f.tar.xz
netdata-4eecd612b3275719f0101e890057d84fa7c4db9f.zip
Refresh patches
-rw-r--r--debian/patches/0001-python-libraries-removed-from-make.patch38
-rw-r--r--debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch10
-rw-r--r--debian/patches/0003-hide-update-button.patch18
-rw-r--r--debian/patches/0004-Debianize-path-to-exim4-binary.patch4
-rw-r--r--debian/patches/0006-use-system-python-yaml-library.patch29
-rw-r--r--debian/patches/series1
6 files changed, 18 insertions, 82 deletions
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0001-python-libraries-removed-from-make.patch
index cb13ac23a..abb39296d 100644
--- a/debian/patches/0001-python-libraries-removed-from-make.patch
+++ b/debian/patches/0001-python-libraries-removed-from-make.patch
@@ -7,13 +7,11 @@ Subject: python libraries removed from make
web/Makefile.am | 35 -----------------
2 files changed, 142 deletions(-)
-diff --git a/python.d/Makefile.am b/python.d/Makefile.am
-index 84c2aea..2996a53 100644
--- a/python.d/Makefile.am
+++ b/python.d/Makefile.am
-@@ -60,110 +60,3 @@ dist_pythonmodules_DATA = \
- python_modules/msg.py \
- python_modules/lm_sensors.py \
+@@ -88,110 +88,3 @@
+ python_modules/third_party/ordereddict.py \
+ python_modules/third_party/lm_sensors.py \
$(NULL)
-
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
@@ -122,8 +120,6 @@ index 84c2aea..2996a53 100644
- python_modules/urllib3/contrib/_securetransport/low_level.py \
- $(NULL)
-
-diff --git a/web/Makefile.am b/web/Makefile.am
-index b587f5a..9f33500 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -4,10 +4,6 @@
@@ -137,7 +133,7 @@ index b587f5a..9f33500 100644
dashboard.html \
dashboard.js \
dashboard_info.js \
-@@ -27,15 +23,6 @@ dist_web_DATA = \
+@@ -27,15 +23,6 @@
version.txt \
$(NULL)
@@ -153,31 +149,7 @@ index b587f5a..9f33500 100644
weblibdir=$(webdir)/lib
dist_weblib_DATA = \
lib/bootstrap-3.3.7.min.js \
-@@ -64,23 +51,11 @@ dist_webcss_DATA = \
- css/bootstrap-theme-3.3.7.min.css \
- css/bootstrap-slate-flat-3.3.7.css \
- css/bootstrap-toggle-2.2.2.min.css \
-- css/font-awesome.min.css \
- css/c3-0.4.11.min.css \
- $(NULL)
-
- webfontsdir=$(webdir)/fonts
- dist_webfonts_DATA = \
-- fonts/glyphicons-halflings-regular.eot \
-- fonts/glyphicons-halflings-regular.svg \
-- fonts/glyphicons-halflings-regular.ttf \
-- fonts/glyphicons-halflings-regular.woff \
-- fonts/glyphicons-halflings-regular.woff2 \
-- fonts/FontAwesome.otf \
-- fonts/fontawesome-webfont.eot \
-- fonts/fontawesome-webfont.svg \
-- fonts/fontawesome-webfont.ttf \
-- fonts/fontawesome-webfont.woff \
-- fonts/fontawesome-webfont.woff2 \
- $(NULL)
-
- webimagesdir=$(webdir)/images
-@@ -107,16 +82,6 @@ dist_webimages_DATA = \
+@@ -105,16 +92,6 @@
images/seo-performance-multi-size.icns \
$(NULL)
diff --git a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
index b1a40b40b..3832543bb 100644
--- a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
+++ b/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
@@ -6,11 +6,9 @@ Subject: remove file serve restrictions for symlinks
src/web_client.c | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
-diff --git a/src/web_client.c b/src/web_client.c
-index 6ec3e11..6d30205 100644
--- a/src/web_client.c
+++ b/src/web_client.c
-@@ -303,8 +303,8 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -382,8 +382,8 @@
snprintfz(webfilename, FILENAME_MAX, "%s/%s", netdata_configured_web_dir, filename);
// check if the file exists
@@ -21,7 +19,7 @@ index 6ec3e11..6d30205 100644
debug(D_WEB_CLIENT_ACCESS, "%llu: File '%s' is not found.", w->id, webfilename);
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "File does not exist, or is not accessible: ");
-@@ -313,8 +313,8 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -392,8 +392,8 @@
}
// check if the file is owned by expected user
@@ -32,7 +30,7 @@ index 6ec3e11..6d30205 100644
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "Access to file is not permitted: ");
buffer_strcat_htmlescape(w->response.data, webfilename);
-@@ -322,20 +322,20 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -401,20 +401,20 @@
}
// check if the file is owned by expected group
@@ -57,7 +55,7 @@ index 6ec3e11..6d30205 100644
error("%llu: File '%s' is not a regular file. Access Denied.", w->id, webfilename);
w->response.data->contenttype = CT_TEXT_HTML;
buffer_strcat(w->response.data, "Access to file is not permitted: ");
-@@ -389,17 +389,17 @@ int mysendfile(struct web_client *w, char *filename) {
+@@ -468,17 +468,17 @@
else if(strstr(filename, ".icns") != NULL) w->response.data->contenttype = CT_IMAGE_ICNS;
else w->response.data->contenttype = CT_APPLICATION_OCTET_STREAM;
diff --git a/debian/patches/0003-hide-update-button.patch b/debian/patches/0003-hide-update-button.patch
index 33697ea67..19a034d0d 100644
--- a/debian/patches/0003-hide-update-button.patch
+++ b/debian/patches/0003-hide-update-button.patch
@@ -6,16 +6,14 @@ Subject: hide update button
web/index.html | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/web/index.html b/web/index.html
-index cd8239d..57d6a75 100644
--- a/web/index.html
+++ b/web/index.html
-@@ -3033,7 +3033,7 @@
+@@ -4393,7 +4393,7 @@
<ul class="nav navbar-nav">
- <li><a href="#" class="btn" data-toggle="modal" data-target="#alarmsModal" title="alarms"><i class="fa fa-bell"></i>&nbsp;<span class="hidden-sm">Alarms&nbsp;</span><span id="alarms_count_badge" class="badge"></span></a></li>
- <li><a href="#" class="btn" data-toggle="modal" data-target="#optionsModal" title="dashboard settings"><i class="fa fa-sliders"></i>&nbsp;<span class="hidden-sm">Settings</span></a></li>
-- <li class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal" title="check for update"><i class="fa fa-cloud-download"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
-+ <li class="hidden-sm" id="updateButton" style="display:none;"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal" title="check for update"><i class="fa fa-cloud-download"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
- <li><a href="https://github.com/firehol/netdata/wiki" class="btn" target="_blank" title="netdata on github"><i class="fa fa-github"></i></a></li>
- <li><a href="https://twitter.com/linuxnetdata" class="btn" target="_blank" title="netdata on twitter"><i class="fa fa-twitter" aria-hidden="true"></i></a></li>
- <li><a href="https://www.facebook.com/linuxnetdata/" class="btn" target="_blank" title="netdata on facebook"><i class="fa fa-facebook-official" aria-hidden="true"></i></a></li>
+ <li id="alarmsButton" title="check the health monitoring alarms and their log" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#alarmsModal"><i class="fas fa-bell"></i>&nbsp;<span class="hidden-sm hidden-md">Alarms&nbsp;</span><span id="alarms_count_badge" class="badge"></span></a></li>
+ <li title="change dashboard settings" data-toggle="tooltip" data-placement="bottom"><a href="#" class="btn" data-toggle="modal" data-target="#optionsModal"><i class="fas fa-cog"></i>&nbsp;<span class="hidden-sm hidden-md">Settings</span></a></li>
+- <li title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
++ <li style="display: none;" title="check for netdata updates<br/>you should keep your netdata updated" data-toggle="tooltip" data-placement="bottom" class="hidden-sm" id="updateButton"><a href="#" class="btn" data-toggle="modal" data-target="#updateModal"><i class="fas fa-cloud-download-alt"></i> <span class="hidden-sm hidden-md">Update </span><span id="update_badge" class="badge"></span></a></li>
+ <li title="the netdata wiki home at github<br/>remember to <b>give netdata a <i class=&quot;fas fa-star&quot;></i></b> !" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://github.com/firehol/netdata/wiki" class="btn" target="_blank"><i class="fab fa-github"></i></a></li>
+ <li title="follow netdata on twitter" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://twitter.com/linuxnetdata" class="btn" target="_blank"><i class="fab fa-twitter"></i></a></li>
+ <li title="like netdata on facebook" data-toggle="tooltip" data-placement="bottom" class="hidden-sm hidden-md"><a href="https://www.facebook.com/linuxnetdata/" class="btn" target="_blank"><i class="fab fa-facebook"></i></a></li>
diff --git a/debian/patches/0004-Debianize-path-to-exim4-binary.patch b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
index 34556a4f0..6e9960fb7 100644
--- a/debian/patches/0004-Debianize-path-to-exim4-binary.patch
+++ b/debian/patches/0004-Debianize-path-to-exim4-binary.patch
@@ -6,11 +6,9 @@ Subject: Debianize path to exim4 binary
conf.d/python.d/exim.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/conf.d/python.d/exim.conf b/conf.d/python.d/exim.conf
-index 07d72c5..dd2663d 100644
--- a/conf.d/python.d/exim.conf
+++ b/conf.d/python.d/exim.conf
-@@ -83,4 +83,4 @@ update_every: 10
+@@ -90,4 +90,4 @@
# AUTO-DETECTION JOBS
local:
diff --git a/debian/patches/0006-use-system-python-yaml-library.patch b/debian/patches/0006-use-system-python-yaml-library.patch
deleted file mode 100644
index ab08fc56d..000000000
--- a/debian/patches/0006-use-system-python-yaml-library.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From: Lennart Weller <lhw@ring0.de>
-Date: Mon, 18 Sep 2017 13:19:18 +0200
-Subject: use system python-yaml library
-
----
- plugins.d/python.d.plugin | 9 +--------
- 1 file changed, 1 insertion(+), 8 deletions(-)
-
-diff --git a/plugins.d/python.d.plugin b/plugins.d/python.d.plugin
-index 03c156f..af200d0 100755
---- a/plugins.d/python.d.plugin
-+++ b/plugins.d/python.d.plugin
-@@ -58,15 +58,8 @@ except (AssertionError, ImportError):
- msg.info('Using python v2')
- except ImportError:
- msg.fatal('Cannot start. No importlib.machinery on python3 or lack of imp on python2')
--# try:
--# import yaml
--# except ImportError:
--# msg.fatal('Cannot find yaml library')
- try:
-- if PY_VERSION == 3:
-- import pyyaml3 as yaml
-- else:
-- import pyyaml2 as yaml
-+ import yaml
- except ImportError:
- msg.fatal('Cannot find yaml library')
-
diff --git a/debian/patches/series b/debian/patches/series
index 835ace226..7c4a6f2ba 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,4 +3,3 @@
0003-hide-update-button.patch
0004-Debianize-path-to-exim4-binary.patch
0005-remove-infographic-for-privacy-breach-reasons.patch
-0006-use-system-python-yaml-library.patch