summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2018-12-29 14:29:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2018-12-29 14:36:25 +0000
commit97ba90b0bbd7fcf6703c412fe8cdcc0f837b9328 (patch)
tree98090e858ba5101fb0d5652ee55d99cd2ebbf226
parentAdding patch to hide social-media buttons in navbar to declutter the interface. (diff)
downloadnetdata-97ba90b0bbd7fcf6703c412fe8cdcc0f837b9328.tar.xz
netdata-97ba90b0bbd7fcf6703c412fe8cdcc0f837b9328.zip
Splitting some patches and grouping them thematically together.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/patches/0001-debian-use-system-packaging.patch (renamed from debian/patches/0007-skip-debian-files-in-upstream-makefile.patch)2
-rw-r--r--debian/patches/0002-debian-use-system-python.patch (renamed from debian/patches/0001-python-libraries-removed-from-make.patch)48
-rw-r--r--debian/patches/0003-debian-use-system-exim4.patch (renamed from debian/patches/0004-debianize-path-to-exim4-binary.patch)2
-rw-r--r--debian/patches/0004-debian-use-python3.patch (renamed from debian/patches/0006-force-usage-of-python3.patch)5
-rw-r--r--debian/patches/0005-debian-remove-infographic.patch (renamed from debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch)2
-rw-r--r--debian/patches/0006-debian-remove-contrib-files.patch49
-rw-r--r--debian/patches/0011-netdata-support-symlinks.patch (renamed from debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch)2
-rw-r--r--debian/patches/0012-netdata-support-kfreebsd.patch (renamed from debian/patches/0008-compile-on-kfreebsd.patch)2
-rw-r--r--debian/patches/0021-gui-remove-update-button.patch (renamed from debian/patches/0003-hide-update-button.patch)2
-rw-r--r--debian/patches/0022-gui-remove-social-media-buttons.patch (renamed from debian/patches/0003-hide-social-media-buttons.patch)3
-rw-r--r--debian/patches/series19
11 files changed, 70 insertions, 66 deletions
diff --git a/debian/patches/0007-skip-debian-files-in-upstream-makefile.patch b/debian/patches/0001-debian-use-system-packaging.patch
index 5040d200..f07e9282 100644
--- a/debian/patches/0007-skip-debian-files-in-upstream-makefile.patch
+++ b/debian/patches/0001-debian-use-system-packaging.patch
@@ -1,5 +1,5 @@
Author: Daniel Baumann <daniel.baumann@progress-linux.org>
-Description: Skip debian files in upstream's makefile.
+Description: Ignore upstream debian packaging.
diff -Naurp netdata.orig/contrib/Makefile.am netdata/contrib/Makefile.am
--- netdata.orig/contrib/Makefile.am
diff --git a/debian/patches/0001-python-libraries-removed-from-make.patch b/debian/patches/0002-debian-use-system-python.patch
index 1389414d..4e329bb7 100644
--- a/debian/patches/0001-python-libraries-removed-from-make.patch
+++ b/debian/patches/0002-debian-use-system-python.patch
@@ -1,5 +1,5 @@
Author: Lennart Weller <lhw@ring0.de>
-Description: python libraries removed from make. remove unused contrib files
+Description: Ignore embedded python modules.
diff -Naurp netdata.orig/collectors/python.d.plugin/Makefile.am netdata/collectors/python.d.plugin/Makefile.am
--- netdata.orig/collectors/python.d.plugin/Makefile.am
@@ -129,49 +129,3 @@ diff -Naurp netdata.orig/collectors/python.d.plugin/python_modules/bases/loaders
except ImportError:
from yaml import SafeLoader as YamlSafeLoader
-diff -Naurp netdata.orig/web/gui/Makefile.am netdata/web/gui/Makefile.am
---- netdata.orig/web/gui/Makefile.am
-+++ netdata/web/gui/Makefile.am
-@@ -46,10 +46,6 @@ dist_noinst_DATA = \
- $(NULL)
-
- dist_web_DATA = \
-- demo.html \
-- demo2.html \
-- demosites.html \
-- demosites2.html \
- dashboard.html \
- dashboard.js \
- dashboard_info.js \
-@@ -107,15 +103,6 @@ dist_webcss_DATA = \
- css/c3-0.4.18.min.css \
- $(NULL)
-
--webfontsdir=$(webdir)/fonts
--dist_webfonts_DATA = \
-- fonts/glyphicons-halflings-regular.eot \
-- fonts/glyphicons-halflings-regular.svg \
-- fonts/glyphicons-halflings-regular.ttf \
-- fonts/glyphicons-halflings-regular.woff \
-- fonts/glyphicons-halflings-regular.woff2 \
-- $(NULL)
--
- webimagesdir=$(webdir)/images
- dist_webimages_DATA = \
- images/alert-128-orange.png \
-@@ -159,15 +146,6 @@ dashboard.js: $(DASHBOARD_JS_FILES)
- if test -f $@; then rm -f $@; fi
- cat $(DASHBOARD_JS_FILES) > $@.tmp && mv $@.tmp $@
-
--webwellknowndir=$(webdir)/.well-known
--dist_webwellknown_DATA = \
-- $(NULL)
--
--webdntdir=$(webdir)/.well-known/dnt
--dist_webdnt_DATA = \
-- .well-known/dnt/cookies \
-- $(NULL)
--
- version.txt:
- if test -d "$(top_srcdir)/.git"; then \
- git --git-dir="$(top_srcdir)/.git" log -n 1 --format=%H; \
diff --git a/debian/patches/0004-debianize-path-to-exim4-binary.patch b/debian/patches/0003-debian-use-system-exim4.patch
index 954c5c7c..bcb0a1b7 100644
--- a/debian/patches/0004-debianize-path-to-exim4-binary.patch
+++ b/debian/patches/0003-debian-use-system-exim4.patch
@@ -1,5 +1,5 @@
Author: Sven Hartge <sven@svenhartge.de>
-Description: Debianize path to exim4 binary
+Description: Debian has exim in /usr/sbin which is not in the default path.
diff -Naurp netdata.orig/collectors/python.d.plugin/exim/exim.conf netdata/collectors/python.d.plugin/exim/exim.conf
--- netdata.orig/collectors/python.d.plugin/exim/exim.conf
diff --git a/debian/patches/0006-force-usage-of-python3.patch b/debian/patches/0004-debian-use-python3.patch
index 04222e79..cc800d25 100644
--- a/debian/patches/0006-force-usage-of-python3.patch
+++ b/debian/patches/0004-debian-use-python3.patch
@@ -1,8 +1,5 @@
Author: Sander Klein <debian-bugs@roedie.nl>
-Description: Force usage of python3
- Debian uses Python2 by default. The netdata package installs the
- Python3 dependencies. So, in order to work correctly it must use
- Python3.
+Description: Debian uses by default python 2 instead of python3.
diff -Naurp netdata.orig/collectors/python.d.plugin/python.d.plugin netdata/collectors/python.d.plugin/python.d.plugin
--- netdata.orig/collectors/python.d.plugin/python.d.plugin
diff --git a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch b/debian/patches/0005-debian-remove-infographic.patch
index e9e68c1a..0571c963 100644
--- a/debian/patches/0005-remove-infographic-for-privacy-breach-reasons.patch
+++ b/debian/patches/0005-debian-remove-infographic.patch
@@ -1,5 +1,5 @@
Author: Lennart Weller <lhw@ring0.de>
-Description: remove infographic for privacy breach reasons
+Description: Remove infographic for privacy breach reasons.
diff -Naurp netdata.orig/web/gui/Makefile.am netdata/web/gui/Makefile.am
--- netdata.orig/web/gui/Makefile.am
diff --git a/debian/patches/0006-debian-remove-contrib-files.patch b/debian/patches/0006-debian-remove-contrib-files.patch
new file mode 100644
index 00000000..eca2319a
--- /dev/null
+++ b/debian/patches/0006-debian-remove-contrib-files.patch
@@ -0,0 +1,49 @@
+Author: Lennart Weller <lhw@ring0.de>
+Description: Remove unused contrib files.
+
+diff -Naurp netdata.orig/web/gui/Makefile.am netdata/web/gui/Makefile.am
+--- netdata.orig/web/gui/Makefile.am
++++ netdata/web/gui/Makefile.am
+@@ -46,10 +46,6 @@ dist_noinst_DATA = \
+ $(NULL)
+
+ dist_web_DATA = \
+- demo.html \
+- demo2.html \
+- demosites.html \
+- demosites2.html \
+ dashboard.html \
+ dashboard.js \
+ dashboard_info.js \
+@@ -107,15 +103,6 @@ dist_webcss_DATA = \
+ css/c3-0.4.18.min.css \
+ $(NULL)
+
+-webfontsdir=$(webdir)/fonts
+-dist_webfonts_DATA = \
+- fonts/glyphicons-halflings-regular.eot \
+- fonts/glyphicons-halflings-regular.svg \
+- fonts/glyphicons-halflings-regular.ttf \
+- fonts/glyphicons-halflings-regular.woff \
+- fonts/glyphicons-halflings-regular.woff2 \
+- $(NULL)
+-
+ webimagesdir=$(webdir)/images
+ dist_webimages_DATA = \
+ images/alert-128-orange.png \
+@@ -159,15 +146,6 @@ dashboard.js: $(DASHBOARD_JS_FILES)
+ if test -f $@; then rm -f $@; fi
+ cat $(DASHBOARD_JS_FILES) > $@.tmp && mv $@.tmp $@
+
+-webwellknowndir=$(webdir)/.well-known
+-dist_webwellknown_DATA = \
+- $(NULL)
+-
+-webdntdir=$(webdir)/.well-known/dnt
+-dist_webdnt_DATA = \
+- .well-known/dnt/cookies \
+- $(NULL)
+-
+ version.txt:
+ if test -d "$(top_srcdir)/.git"; then \
+ git --git-dir="$(top_srcdir)/.git" log -n 1 --format=%H; \
diff --git a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch b/debian/patches/0011-netdata-support-symlinks.patch
index b0b7d743..08102115 100644
--- a/debian/patches/0002-remove-file-serve-restrictions-for-symlinks.patch
+++ b/debian/patches/0011-netdata-support-symlinks.patch
@@ -1,5 +1,5 @@
Author: Lennart Weller <lhw@ring0.de>
-Description: remove file serve restrictions for symlinks
+Description: Remove file serve restrictions for symlinks.
diff -Naurp netdata.orig/web/server/web_client.c netdata/web/server/web_client.c
--- netdata.orig/web/server/web_client.c
diff --git a/debian/patches/0008-compile-on-kfreebsd.patch b/debian/patches/0012-netdata-support-kfreebsd.patch
index 9e6945cc..8c244953 100644
--- a/debian/patches/0008-compile-on-kfreebsd.patch
+++ b/debian/patches/0012-netdata-support-kfreebsd.patch
@@ -1,5 +1,5 @@
Author: Lennart Weller <lhw@ring0.de>, Daniel Baumann <daniel.baumann@progress-linux.org>
-Description: compile on kfreebsd/hurd
+Description: Build on kfreebsd.
diff -Naurp netdata.orig/collectors/apps.plugin/apps_plugin.c netdata/collectors/apps.plugin/apps_plugin.c
--- netdata.orig/collectors/apps.plugin/apps_plugin.c
diff --git a/debian/patches/0003-hide-update-button.patch b/debian/patches/0021-gui-remove-update-button.patch
index bbb4c027..f64e9f69 100644
--- a/debian/patches/0003-hide-update-button.patch
+++ b/debian/patches/0021-gui-remove-update-button.patch
@@ -1,5 +1,5 @@
Author: Federico Ceratto <federico.ceratto@gmail.com>
-Description: hide update button
+Description: Remove update button in web gui.
diff -Naurp netdata.orig/web/gui/index.html netdata/web/gui/index.html
--- netdata.orig/web/gui/index.html
diff --git a/debian/patches/0003-hide-social-media-buttons.patch b/debian/patches/0022-gui-remove-social-media-buttons.patch
index 33fca624..ad071181 100644
--- a/debian/patches/0003-hide-social-media-buttons.patch
+++ b/debian/patches/0022-gui-remove-social-media-buttons.patch
@@ -1,3 +1,6 @@
+Author: Daniel Baumann <daniel.baumann@progress-linux.org>
+Description: Remove social media buttons in web gui.
+
diff -Naurp netdata.orig/web/gui/index.html netdata/web/gui/index.html
--- netdata.orig/web/gui/index.html
+++ netdata/web/gui/index.html
diff --git a/debian/patches/series b/debian/patches/series
index 39fa3eb8..79fe35ea 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,9 +1,10 @@
-0001-python-libraries-removed-from-make.patch
-0002-remove-file-serve-restrictions-for-symlinks.patch
-0003-hide-update-button.patch
-0003-hide-social-media-buttons.patch
-0004-debianize-path-to-exim4-binary.patch
-0005-remove-infographic-for-privacy-breach-reasons.patch
-0006-force-usage-of-python3.patch
-0007-skip-debian-files-in-upstream-makefile.patch
-0008-compile-on-kfreebsd.patch
+0001-debian-use-system-packaging.patch
+0002-debian-use-system-python.patch
+0003-debian-use-system-exim4.patch
+0004-debian-use-python3.patch
+0005-debian-remove-infographic.patch
+0006-debian-remove-contrib-files.patch
+0011-netdata-support-symlinks.patch
+0012-netdata-support-kfreebsd.patch
+0021-gui-remove-update-button.patch
+0022-gui-remove-social-media-buttons.patch